Community
Showing results for 
Search instead for 
Do you mean 
Reply

Login failed for user 'ACTADMIN'

Highlighted
New Member
Posts: 2
Country: United_Kingdom

Login failed for user 'ACTADMIN'

I'm trying to move Act from a desktop PC to a server.

Act version 20.1.120 (update8)

The server is SBS2011 (effectively 2008 R2)

Older versions of SQL Server are already present and are being used.

 

Therefore I cannot follow the guidance here: https://community.act.com/t5/Act-Premium/Login-failed-for-user-ACTADMIN/td-p/20195

which pretty much says destroy the entire universe and start afresh!

Using a Hyper-V instance might work (a blunt instrument for a seemingly simple task) but the server isn't really beefy enough to start running Hyper-V.

 

In my case, installing Act! does not install a fresh instance of SQL Server 2014 Express as I would expect. It seems to see the existing SQL instances and just skip the SQL part of the installation, and then complain when you try to run Act!.

 

So, I install SQL Server 2014 Express manually, as directed here... 

http://kb.act.com/app/answers/detail/a_id/38099/~/how-to-manually-create-the-microsoft-sql-server-20...

 

The instructions are clear. I have tried both options. i.e. Act Installed first, or Act installed after SQL Server. Both produce the same error.

Login failed for user 'ACTADMIN'

How can this be so difficult? Act! gets it's own SQL Server instance, nothing else is using it. So why can't the installer just get it right?

I've wasted an entire day on this, install, reboot, test, uninstall, reboot, repeat.

 

Therefore any useful info would be very much appreciated.

 

Greg

 

 

Highlighted
New Member
Posts: 2
Country: United_Kingdom

Re: Login failed for user 'ACTADMIN'

UPDATE!

I uninstalled version 20, left my SQL 2014 Express instance alone, and installed version 21.

All is well. No need for my rant after all!