Community
Showing results for 
Search instead for 
Do you mean 
Reply
Accepted Solution

It has been too long since you connected Act! to the internet. Your Act! license has been deactivated. To reactivate, please connect to the internet.

Moderator
Posts: 451
Country: United_Kingdom

Re: It has been too long since you connected Act! to the internet. Your Act! license has been deactivated. To reactivate, please connect to the intern

[ Edited ]

Hi Brenda,

 

As you mentioned that you do not use this machine often, could it of been 30 days since you last used it / had an internet connection?

Due to the way subscription licences work they will be deactivated if they cannot confirm the subscription is active.

Copper Contributor
Posts: 9
Country: USA

Re: It has been too long since you connected Act! to the internet. Your Act! license has been deactivated. To reactivate, please connect to the intern

We recently encountered this error due to an internet outage caused by a faulty modem.

 

By the time our service provider made it out to swap out the modem, we'd been offline for 4 days including the weekend.

 

It was frustrating enough to deal with the loss of access to email, etc, but I had thought I'd at least be able to work with Act. Unfortunately, when I went to log in, I got a message about it being deactivated.

 

I don't expect to have a lot of incidents like this, but it is frustrating that Swiftpage would revoke access to your own data without some way of easily working around it for situations like this.I hadn't realized our license was so conditional. I'm glad our sales reps got lucky and didn't have the same issue. Only I and the General Manager had such unlucky timing. Still it was very disappointing and frustrating.

 

Becky

Administrator
Posts: 4,032
Country: United_Kingdom

Re: It has been too long since you connected Act! to the internet. Your Act! license has been deactivated. To reactivate, please connect to the intern

Hi Becky,

 

Act! has a built in timer that checks for registration over the internet at regular intervals. It seems that in you and your GM's case, one of these checks happened while your internet was down. This is rather unfortunate that it happened so soon after the internet became unavailable.

 

It would be possible to regain access to Act! if this were to occur again, by temporarily connecting the PC to any internet connection and opening Act! (i.e. mobile hotspot, or public WiFi). Once the check occurs, you could then disconnect the internet again for a while without losing access.

 

It's worth noting that a broadband internet connection is listed as a system requirement for Act!

Nickel Contributor
Posts: 795
Country: USA

Re: It has been too long since you connected Act! to the internet. Your Act! license has been deactivated. To reactivate, please connect to the intern

I have a client with new laptop Act! Premium v20. His registration worked fine 3 weeks ago, as soon as he disconnects from the internet and tries to open Act! gets the message "It's been too long..." he was just connected. Deleted the subscription number registered and also deleted the registration.xml file and still having the issue. The IT person is reluctant to add all the inbound ports due to security risk.  It doesn't make sense that he is getting this error if he was just connected. Any ideas?

 

Shannon

 

Shannon Hawthorne (formerly Taylor)
essentials software
Atlanta, GA
New Member
Posts: 8
Country: USA

Re: It has been too long since you connected Act! to the internet. Your Act! license has been deactivated. To reactivate, please connect to the intern

I am an experienced IT Admin.  Have worked in IT for over 20 years.  This issue is still not resolved.  I had to work with both ACT! and a local ACT!  Consultant to get this "patched" where my people could work.  I am almost certain that it has to do with inbound ports not being open on the firewall for Protexis to communicate back to the machine and verify that the serial number is valid.  This quite frankly is ridiculous. There are numerous pieces of software that validate their serial numbers regularly and ACT!  is the only one that is having ANY issue.  You need to work with Protexis to get this fully and completely resolved.  Yes, I have a valid and continuous internet connection.  Yes, I have worked as I said at length with ACT! support (who again quite frankly just continue to read and lead me through the same KB articles over and over.)  Somehow they finally customized my licensing to not have to check regularly.  But I still have to plug in a wireless usb adapter and connect to my phone for internet to get around my firewall and register each machine.  If they would simply tell me the exact port numbers I need open I would create a route in the firewall.  Also, if we are using a server inside the firewall to host ACT!  why in the world can it not be the sole owner of the licensing and client machines simply check with it and not be forced to go to the internet to validate licensing?  There are so many better ways to deal with this!  Please fix this once and for all or we will be forced to change contact management providers VERY SOON!!

Bronze Elite Contributor
Posts: 1,479
Country: United_Kingdom

Re: It has been too long since you connected Act! to the internet. Your Act! license has been deactivated. To reactivate, please connect to the intern

Given that you have been in touch with ACT support this may have been covered but I offer the following anyway.

 

Configure your server (or / and router)  to unblock Port 443 and allow access to license.ntitles.net

 

I am assuming this is still the valid address for Proteus authorization updating of the licence. If not I invite others to correct this message.  

Employee
Posts: 200
Country: USA

Re: It has been too long since you connected Act! to the internet. Your Act! license has been deactivated. To reactivate, please connect to the intern

Add exceptions to allow traffic to/from the following URLs:
https://69.20.35.129
https://license.ntitles.net

 

TCP 80 (Used for product Registration, also default Web Port if using Act! Internet Synchronization or Act! Premium for Web)
TCP 8080 (Used for product Registration)
TCP 443 (Used for product Registration)
TCP 1690 (Used for product Registration)

Nickel Contributor
Posts: 795
Country: USA

Re: It has been too long since you connected Act! to the internet. Your Act! license has been deactivated. To reactivate, please connect to the intern

Will try this tomorrow but IT group supporting the client does not want to leave these ports open due to security risk. As others have mentioned, this is not an ideal solution and should not be happening if the user was just connected to the internet and logged into Act! successfully. I thought this error message should only appear if the user has not bee in Act! for 30 days without internet connection.

 

Shannon

 

Shannon Hawthorne (formerly Taylor)
essentials software
Atlanta, GA
New Member
Posts: 8
Country: USA

Re: It has been too long since you connected Act! to the internet. Your Act! license has been deactivated. To reactivate, please connect to the intern

Again, for anyone in IT this is a known used port for secure email access.  If a company (like mine) is running an Exchange server internally that port must have a static route to the email server.  So, herein lies the problem.  The return comms from Protexis are being static routed to my email server.  Not good.

 

 

Highlighted
New Member
Posts: 8
Country: USA

Re: It has been too long since you connected Act! to the internet. Your Act! license has been deactivated. To reactivate, please connect to the intern

For a company with a moderately sophisticated internal network (running IIS on two servers and hosting email internally as well as back office financial software, ftp server and others.  This is simply not possible.  80 and 8080 and 443 all have static routes through my firewall to servers serving applications related to those ports.  It is clear that many folks have and still are running into this.  I would think that Protexis would use ports not commonly used for other very standard configurations (80 for http traffic, 8080 for https traffic and 443 for secure email)  I understand that ACT is not for the large enterprise business but this configuration is causing issues for small and medium business with moderately complex networks (pretty common)  If I were working at home or a very small business this might work as my firewall would like be set to some very default settings.  Based on what you're telling me though we will very likely be changing contact software solutions soon.