Community
Showing results for 
Search instead for 
Do you mean 
Reply

Issue creating Notes - error appears on submit: \urtf1\ansi\ansicpg65001\deff0\deflang1033

New Member
Posts: 4
Country: United_Kingdom

Issue creating Notes - error appears on submit: \urtf1\ansi\ansicpg65001\deff0\deflang1033

[ Edited ]

We use Act Premium ver 21.0.

 

When we insert a note against a contact, instead of our actual note appearing, the following code appears instead:

 

{\urtf1\ansi\ansicpg65001\deff0\deflang1033{\fonttbl{\f0\fnil\fcharset0 Microsoft Sans Serif;}}
\viewkind4\uc1\pard\f0\fs17 client requires a call back tomorrow\par}

 

We have 5 Windows 7 computers running Office 2019.  These machines insert notes correctly.

We have 2 Windows 10 computers running Office 2019.  These also insert notes correctly.

 

But we have two more Windows 10 computers running Office 2019, and these are the two that present this error code instead of the actual note.


Both machines are brand new.  They have not been imaged from the same disk, and they were sourced at different times.

 

They both run Windows 10 Build 1809.  Swift Page have confirmed it is not a build issue, but have no idea how to fix this.  

 

We have re-built one of the new computers from scratch (they are both Dell Optiplex machines), but the problem remains.

 

SFC /scannow reveals no issues with either machine.  No other issues present anywhere else (ie. Word, Excel, Outlook, Print, file sharing etc all work perfectly well.  It is just NOTES in ACT that will not work.

 

The machines have been tested with a local demo database, and the same symptoms present.

 

Any thoughts anyone?

 

 

Platinum Elite Contributor
Posts: 6,853
Country: USA

Re: Issue creating Notes - error appears on submit: \urtf1\ansi\ansicpg65001\deff0\deflang1033

The notes text and history details are stored in RTF (Rich Text Format). On the problem machines is the actual database note content. In ACT! the RTF should be interpreted and displayed as normal text. On the problem machines that's not happening. In the ACT! reports there is an option for showing the RTF or the interpreted text. I don't know of any such option in for the screen display. My guess is the problem is with Windows.
Roy Laudenslager
Retired ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
New Member
Posts: 4
Country: United_Kingdom

Re: Issue creating Notes - error appears on submit: \urtf1\ansi\ansicpg65001\deff0\deflang1033

[ Edited ]

Thanks for the reply Roy.   Act is the only application that errors, so perhaps it is better described as ACT-CONFLICTING-WITH-WINDOWS (especially as the problem exists on two entirely different machines).

 

In any case, where to start - especially if Swiftpage cannot advise on exactly what setting in windows it might be conflicting with?

 

Where would you start Roy?

 

Platinum Elite Contributor
Posts: 6,853
Country: USA

Re: Issue creating Notes - error appears on submit: \urtf1\ansi\ansicpg65001\deff0\deflang1033

RTF may or may not be used by any other application on your machine. However the ACT! Notes History report does interpret the RTF for the Note text and History details so I would try running that report and see if the text is displayed correct.
Roy Laudenslager
Retired ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
New Member
Posts: 4
Country: United_Kingdom

Re: Issue creating Notes - error appears on submit: \urtf1\ansi\ansicpg65001\deff0\deflang1033

The report "notes/History" doesnt run - I get this error in an ACT window:

 

FILE FORMAT IS NOT VALID

 

https://www.screencast.com/t/xSC216zKIAX

 

All other reports run without issue.  Does that tell you anything?

Platinum Elite Contributor
Posts: 6,853
Country: USA

Re: Issue creating Notes - error appears on submit: \urtf1\ansi\ansicpg65001\deff0\deflang1033

I don't have any definite answer. The fact that the Notes History report only fails indicates the problem is with the RTF interpreter. When you rebuilt the one system did you reinstall Windows? One guess is that some other program installed their own RTF interpreter and ACT! doesn't recognize it. A wild suggestion would be to image a working system onto the problem system.
Roy Laudenslager
Retired ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
New Member
Posts: 4
Country: United_Kingdom

Re: Issue creating Notes - error appears on submit: \urtf1\ansi\ansicpg65001\deff0\deflang1033

[ Edited ]

Hi Roy,

thanks for your feedback.  We have found the issue and it has been resolved.

 

It turns out Swiftpage did not thoroughly test all of the features on Windows 10 build 1803.  Had they done so, they would have discovered this issue themselves.   A new feature of Windows 10 was enabled.  It was not a feature that was in "error state" - it was just set to on (by default).  Had Swiftpage tested with this feature enabled themselves, they would have found the problem - and put out a broadcast telling its clients to ensure this feature was unticked.  Ricoh did just that in April 2018 when they found that the feature caused issues when ticked.

 

Disappointed in Swiftpage over this.  The client pays a monthly premium and they understood that Act invested in checking all new features of Windows.  They cleared missed this feature!!

 

 

 

 

Highlighted
New Member
Posts: 1
Country: United_Kingdom

Re: Issue creating Notes - error appears on submit: \urtf1\ansi\ansicpg65001\deff0\deflang1033

Hi Sally

 

I'm having the same issue. What feature are you referring to?

 

Keith

Silver Contributor
Posts: 1,781
Country: United_Kingdom

Re: Issue creating Notes - error appears on submit: \urtf1\ansi\ansicpg65001\deff0\deflang1033

This article may help. Moderators please get an ACT knowledgebase article out about this.

 

http://support.ricoh.com/html_gen/util/Info/Win10_Apr_2018.html