Community
Showing results for 
Search instead for 
Do you mean 
Reply

Intermittent Red X in Act Premium Header upon Launch

New Member
Posts: 7
Country: USA

Intermittent Red X in Act Premium Header upon Launch

Version: Act! Premium Version 20.1.120.0, Update 3

Operating System: Windows Server 2008 R2 Standard

Database: Shared Database across Network

 

We have users seeing intermittent red X's appearing in the Act header upon launch. This goes away when you close and re-start Act (without a machine reboot) but then it comes back seemingly at random. When we get this red X we are also unable to scroll or change screens in ACt. Below is a screenshot of where we are seeing this (the blue line was added by the user who took the screenshot):

 

ActRedX.png

The environment is set up where multiple users can RDP into the server and then launch Act from within the RDP session. The Act Application and Act Database are installed on 2 separate Virtual Servers hosted on the same physical server. We do have the Act Network Sync Service also installed allowing remote databases to access this database but this screenshot was not from one of those remote database deployments. 

 

Has anyone seen this before and are there troubleshooting steps/configuration I need to perform to resolve this? 

Employee
Posts: 244
Country: USA

Re: Intermittent Red X in Act Premium Header upon Launch

Maybe try changing how often .Net refreshes :

 

  1. Using notepad (or other text editor), open the configuration file located at (for example): C:\Program Files (x86)\ACT\Act for Windows\Act!.exe.config
  2. Locate the following line:

    <add key="TrimRAMInterval" value="120" />

  3. Decrease the default value "120" to a smaller number. This is the time in minutes between memory cleanups.

    Note: Setting the value to "0" will prevent the cleanup function from running.

  4. Continue using Act! as normal to test for the issue reoccurring.

 

 

There is also update 4 and 5 you can apply if that does not help.