Community
Showing results for 
Search instead for 
Do you mean 
Reply

Installation Problem

New Member
Posts: 1
Country: United_Kingdom

Installation Problem

Hi

 

We are trying to install Act 2012 Premium on an SBS 2011 Essentials server.

 

Installation exits with an error before installing SQL server.

 

We have tried installation on 2 new servers with the same result.

 

Has anyone encountered this behavior and does anyone know a solution.

 

TIA

Bronze Elite Contributor
Posts: 2,546
Country: New_Zealand

Re: Installation Problem

[ Edited ]

The ACT! System Requirements found here System Requirements

You will see that SBS 2011 is not supported. We have done it ourselves with some effort, but be aware that Microsoft would see that having a SQL database (ACT!) on a Domain Contoller (SBS) is a security risk.

 

 

Graeme Leo
Xact Software - consultants and developers
Follow us on Twitter and check out our Blog


New Member
Posts: 7
Country: United_Kingdom

Re: Installation Problem

Gleo,

Just out of interest what did you actually do to get the software working on SBS 2011?

I am also getting the same error messages as bobhar.

Thanks,
Jason
Bronze Elite Contributor
Posts: 2,546
Country: New_Zealand

Re: Installation Problem

Jason,

Yes, we haven't had a problem with installing SQL and ACT! 2012 Premium on MS Server 2011 yet. There are problems with installing ACT! Premium for Web because of the changes to IIS made in Server 2011 but they can be worked around. 

Graeme Leo
Xact Software - consultants and developers
Follow us on Twitter and check out our Blog


New Member
Posts: 7
Country: United_Kingdom

Re: Installation Problem

Hi Graeme,

Thanks for your reply. I've tried installing ACT 2012 Premium on two different SBS 2011 Essential servers and I also get an error at the stage where it installs the SQL database. Much like the problem described above.

The error message is "Sage ACT! pre-requisite has encountered an error and needs to close".

Have you tried the install on a SBS Essentials server at all?

Thanks,
Jason
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Installation Problem

Hello Jason,
Welcome to the Sage ACT! Community. For the error you described, please see if the information in the following Knowledgebase article helps to resolve:
http://kb.Sagesoftwareonline.com/cgi-bin/Sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2848...

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 7
Country: United_Kingdom

Re: Installation Problem

Hi Greig,

All was going great until I got to the last step!

It's when I use the SecurityCmdLnApp.exe tool to reset the SA password.

I get the following string in the command prompt.

 

 

Photobucket
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Installation Problem

This usually indicates an issue with the SA password. Try this:

- Save the attached file to your computer and rename it to "FallbackSQLPwdReset.bat". This file is also found in the "Dependencies" folder in the ACT! installation media

- Copy this batch file to your ACT! program files directory C:\Program Files\ACT\Act for Windows (will be "Program Files (x86) for a 64-bit machine)

- Double-click the file to run it

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 7
Country: United_Kingdom

Re: Installation Problem

I ran that batch file and this time it came up with:

 

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Installation Problem

Try the suggested solution in this KB article:
http://kb.Sagesoftwareonline.com/cgi-bin/Sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2573...

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.