Community
Showing results for 
Search instead for 
Do you mean 
Reply

Install Problems - ACT! Premium 10

New Member
Posts: 1
Country: USA

Install Problems - ACT! Premium 10

Hello.
 
I am trying to reinstall ACT! on my WinXP SP2 laptop after a complete (read HDD format) clean re-install of the OS. This was done to try to fix earlier problems with ACT! and Outlook 2003.
 
Now the laptop has Office Suite 2007 (with Outlook 2007).
 
Lastnight I was installing ACT! 10 from the media on our corporate server. It got pretty close to the end and gave me the following error message:
 
"ACT! By Sage---- Could not load file or assembly 'ACT.framework.Interop, version=10.1.199.0, culture=neutral,Public key token=XXXXXXXXXXXXXX' or one of its dependencies. The system cannot find the file specified".
{The XXXXXXX had some values, if they are important I can provide - didn't know if it was a license or something so I did not post}
 
Then the install closed.
 
Starting again this morning I get the following message when I try to run the install again:
 
"ACT! Premium Setup----An earlier version of ACT! has been detected. To install {0}, uninstall your previous version and start this installation again."
 
So here is where the fun starts...ACT! does not show up in the Add or Remove Programs although there are a bunch of references in the Registry. I am not about to start deleting this stuff without some instruction.
 
Has anybody seen this? Any recommendations?
 
Also, is there going to be any love with ACT! 10 and Outlook 2007?
 
Thanks to all
Nickel Elite Contributor
Posts: 595
Country: USA

Re: Install Problems - ACT! Premium 10

There is an ACT! uninstaller utility available through the Knowledge Base. Search for Article ID 19338. The download is at the bottom of the article.
 
 
Roy Laudenslager
Techbenders
 
Roy Laudenslager
ACT! Certified Consultant
Techbenders
royel@techbenders.com
Copper Contributor
Posts: 97
Country: USA

Re: Install Problems - ACT! Premium 10

And if the uninstaller utility doesn't work, check out the manual uninstall document referenced in the following thread:
 
 
HTH,
jason
 
Jason Sellers
ACT! Engineer 2000-2007
Platinum Elite Contributor
Posts: 14,388
Country: Australia

Re: Install Problems - ACT! Premium 10

When the install has failed or when the .Net Framework has issues, I find doing a full clean uninstall/reinstall the best solution
 
This is a procedure I wrote to get the most clean install possible:
Uninstall any version of ACT!
Use the Uninstaller.exe from the ACT! KB 19338
Uninstall .Net Framework (all versions)
Uninstall MS SQL from Control Panel if it's still there
Uninstall MSXML Services from Control Panel if it's still there
Perform a Selective restart with MSCONFIG as per ACT! KB 14499
Install .Net 2.0 Framework from MS web site (only for XM, not Vista)- http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en
Manually install MS SQL as per ACT! KB 19386
Install ACT! 10 and the 10.01 patch
Restore from Selective Startup Mode with MSCONFIG
Reboot
Copper Contributor
Posts: 70
Country: USA

Re: Install Problems - ACT! Premium 10

I agree with Mike on this.  His walk through is the best solution for uninstalling and re-installing ACT! on your machines, however if you have purchased any add-ons or plug-ins for ACT! you might run into other problems.  I have had nothing but trouble with machines here that had WinFax and or FaxAdmin installed on them.  It didnt matter when or how I uninstalled them, there were issues with re-installing ACT!10 and huge issues getting other Add-ons installed after the upgrade.
Platinum Elite Contributor
Posts: 14,388
Country: Australia

Re: Install Problems - ACT! Premium 10

I should add uninstall any add-ons before uninstalling ACT! and make sure you have the latest build of them before reinstalling
Tuned Listener
Posts: 113
Country: USA

Re: Install Problems - ACT! Premium 10

I am having a similar problem.  I downloaded the trial version of ACT! 2008.  I ended up purchasing the product but have not been able to register. 
 
I am using Vista.  I spent several hours yesterday after trying to install the new version and receiving error messages that the previous message had to be installed first.  
"ACT! Premium Setup----An earlier version of ACT! has been detected. To install {0}, uninstall your previous version and start this installation again."  It wasn't available in the control panel as a program to uninstall, but I found the ACT! uninistaller and the message was that it was uninstalled correctly.
 
However, after running the new installation and receiving confirmation that the installation was successful, when launching ACT!,  the message is that "your trial period has expired....."  I click the option to register the product, but it says that I must have administrator access to perform this function.  What administrator access?  Administrator access within ACT! or Windows security.  I am an administrator on this laptop.
 
It appears that something is not getting removed in the registry files in the uninstallation.  I have tried uninstalling and reinstalling multiple times.  I even went in to the registry to remove ACT items after the uninistallation. And there were items left behind afater the uninstallation.  I'm not comfortable going into the registry without further instruction.  I tried reinstalling in a new directory.  Now I get the message,  "Your trial persiod has expired...."  It should not be this difficult to switch from a trial version to registered version! 
 
Does anyone have suggestions?
Nickel Super Contributor
Posts: 584
Country: USA

Re: Install Problems - ACT! Premium 10

Hi,

Since you are running on Vista, right click on the ACT Icon and select "Run as Administrator" you should then be able to register the program without issue.