Community
Showing results for 
Search instead for 
Do you mean 
Reply

Import problems

New Member
Posts: 16
Country: USA

Import problems

Hello,

 

I am using ACT! 2009 and am having problems with importing. I have a list of email addresses that I exported for an Exact Target list, and now want to take those addresses and merge them back into the database along with a new column that contains data for a field (to track who opted in and out). I have the excel file in a .csv format, and have gone through the wizard a few times and on different computers. The import took 4 hours, for only 200 contacts, and didn't even work.

 

I have my duplicate checking set to e-mail first, and I "merge" as the option for match e-mailed addresses, and then "add" if I don't have the e-mail.

 

Anyone know what's up?

 

Moderator
Posts: 4,395
Country: USA

Re: Import problems

Try adding more criteria to duplicate matching.  Export contact, company, and email to a CSV file, then add the additional info to the CSV.  After doing that setup duplicate checking to match on contact, company and email and do the import again.  Create a backup of the database before doing the import.

 

Run a reindex on your database from Tools > Database Maintenance > Check and Repair to improve import performance.

 

Platinum Elite Contributor
Posts: 14,389
Country: Australia

Re: Import problems

Is the new field blank? The ACT! import/merge can't update a field with data.

 

If source records match destination records (according the your Duplicate Matching Criteria), merge options allow you to combine the data in duplicate records, replace with the newest data, replace with the source data or leave the data unchanged. This applies only to duplicate records:

Merge - Imports data only into fields that are blank in the destination record
Replace with the newest contact
- Populates all fields with the newest data from either record
Replace with the source contact - Replaces all fields with source data
Do not change - Leaves all data in destination record unchanged

 

As David suggests, maybe try adding a couple of extra fields to the dupe check.

 

Also, what is the field type? If a checkbox, you need to use 1,0 in the CSV as per this ACT! Knowledge Base article -

http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=1435...

 

If you're trying to update a field that already has data, you need to use an addon like itImport

New Member
Posts: 16
Country: USA

Re: Import problems

The field is blank, and allows for character entry.

 

I don't know how I could possibly enter in more contact data to help with the duplicate checking when I only have email addresses...I would have to do a lookup by every single contact and find their info and then manually enter it into the excel spreadsheet to import it back into the list????

 

 

Is there another way for ACT! to match the emails to a contact. I feel like this is simple and it should work but it's not.

 

Maybe I should just look up the contacts manually and then just enter the contact info into the field myself.

 

What do you think 

Platinum Elite Contributor
Posts: 14,389
Country: Australia

Re: Import problems

You could try exporting the ACT! data again, with Contact, Phone, Email (from the Contact List - Export to Excel)

 

Then merge the extra field in Excel as per http://support.microsoft.com/kb/211802

 

Then try merging back with the additional fields for dupe checking