Community
Showing results for 
Search instead for 
Do you mean 
Reply
Accepted Solution

Hosting Web Access on my desktop

Copper Contributor
Posts: 18
Country: USA

Re: Hosting Web Access on my desktop

Hi again. Just hit a road bump. I am at the last step, which is to sync from the remote database. I've tried but I get the error:

ACT! is unable to connect to the sync server. Check to be sure the "accept incoming sync" is enabled in the main database and that the Network sync service is running. Also be sure you are connected to your network. Contact your administrator for assistance.
Platinum Elite Contributor
Posts: 14,554
Country: Australia

Re: Hosting Web Access on my desktop

Copper Contributor
Posts: 18
Country: USA

Re: Hosting Web Access on my desktop

It's the port forwarding part. I'm pretty sure I got the firewall down. However, I am having a hard time port forwarding. I have a Netgear N300 Wireless ADSL2+ Modem Router DGN2200. Everytime I try to add ACT, I get that it is in conflict with another service.
Copper Contributor
Posts: 18
Country: USA

Re: Hosting Web Access on my desktop

What's even weirder now is that when I select both TCP/UDP. I get a message that says the service name "ACT" is already in use but it's not in the list of my services. I tried using 65100 and 80 with no success.
Platinum Elite Contributor
Posts: 14,554
Country: Australia

Re: Hosting Web Access on my desktop

Are you using Internet sync service or Network sync service?

Internet - most likely on port 80
network - most likely on 65100

Try a different name
Copper Contributor
Posts: 18
Country: USA

Re: Hosting Web Access on my desktop

The Application Sync guide says to use Network sync. What do I put for the IP address though?
Platinum Elite Contributor
Posts: 14,554
Country: Australia

Re: Hosting Web Access on my desktop

If you'll be synchronising from inside your network, then the IP of the server

If you'll be synchronising on the road, then the public IP + you'll need to set up port forwarding on the router
Copper Contributor
Posts: 18
Country: USA

Re: Hosting Web Access on my desktop

So you are saying that if my partners, who live far away, want to synchronize from their computers I need to use public IP? I've done all of the necessary step except port forwarding on my router. Is the public IP the same as my external IP?
Platinum Elite Contributor
Posts: 14,554
Country: Australia

Re: Hosting Web Access on my desktop

Copper Contributor
Posts: 18
Country: USA

Re: Hosting Web Access on my desktop

[ Edited ]

Here is my current situation. I was able to create a port forward in my netgear configuration. This is how it looks:

(Here's my router online manual for reference ftp://downloads.netgear.com/files/DGN2200_UM_3Feb11.pdf)

Ports - Custom Service

Service Name - ACT
Service Type - TCP
Starting Point - 80
Ending Point - 80

Server IP Address - 192.168.0.80

(The last part, 80, was a blank box and I filled it in with 80 because that was what the example showed in the Port Forwarding knowledge base article on ACT website.)

So I tried syncing again today and I still get the same error. I checked the sync log on the remote database, via Team Viewer. This is what the log showed:


======== SYNC SESSION - 6/29/2011 10:20:51 PM ========

[ Info | 6/29/2011 10:20:51 PM ]Message: Sync remote client created.
[ Error | 6/29/2011 10:20:57 PM ]Message: ACT! is unable to connect to the sync server. Check to be sure "accept incoming sync" is enabled in the main database and that the Network sync service is running. Also be sure you are connected to your network.

======== SYNC SESSION - 6/28/2011 10:42:41 PM ========

[ Info | 6/28/2011 10:42:41 PM ]Message: Sync remote client created.
[ Error | 6/28/2011 10:42:47 PM ]Message: ACT! is unable to connect to the sync server. Check to be sure "accept incoming sync" is enabled in the main database and that the Network sync service is running. Also be sure you are connected to your network.

======== SYNC SESSION - 6/28/2011 10:37:31 PM ========

[ Info | 6/28/2011 10:37:31 PM ]Message: Sync remote client created.
[ Error | 6/28/2011 10:37:36 PM ]Message: ACT! is unable to connect to the sync server. Check to be sure "accept incoming sync" is enabled in the main database and that the Network sync service is running. Also be sure you are connected to your network.

======== SYNC SESSION - 6/28/2011 10:34:16 PM ========

[ Info | 6/28/2011 10:34:16 PM ]Message: Sync remote client created.
[ Error | 6/28/2011 10:34:21 PM ]Message: ACT! is unable to connect to the sync server. Check to be sure "accept incoming sync" is enabled in the main database and that the Network sync service is running. Also be sure you are connected to your network.

======== SYNC SESSION - 6/28/2011 10:31:14 PM ========

[ Info | 6/28/2011 10:31:14 PM ]Message: Sync remote client created.
[ Error | 6/28/2011 10:31:19 PM ]Message: ACT! is unable to connect to the sync server. Check to be sure "accept incoming sync" is enabled in the main database and that the Network sync service is running. Also be sure you are connected to your network.

======== SYNC SESSION - 6/28/2011 10:28:37 PM ========

[ Info | 6/28/2011 10:28:37 PM ]Message: Sync remote client created.
[ Error | 6/28/2011 10:28:42 PM ]Message: ACT! is unable to connect to the sync server. Check to be sure "accept incoming sync" is enabled in the main database and that the Network sync service is running. Also be sure you are connected to your network.

======== SYNC SESSION - 6/28/2011 10:25:47 PM ========

[ Info | 6/28/2011 10:25:47 PM ]Message: Sync remote client created.
[ Error | 6/28/2011 10:25:52 PM ]Message: ACT! is unable to connect to the sync server. Check to be sure "accept incoming sync" is enabled in the main database and that the Network sync service is running. Also be sure you are connected to your network.

======== SYNC SESSION - 6/28/2011 10:24:50 PM ========

[ Info | 6/28/2011 10:24:50 PM ]Message: Sync remote client created.
[ Error | 6/28/2011 10:24:55 PM ]Message: ACT! is unable to connect to the sync server. Check to be sure "accept incoming sync" is enabled in the main database and that the Network sync service is running. Also be sure you are connected to your network.

Any help is very much appreciated. I will still be trying out other options in the meantime.