Community
Showing results for 
Search instead for 
Do you mean 
Reply

Histories disappear

Copper Contributor
Posts: 60
Country: United States

Histories disappear

The Regarding & Details field in the History tab seem to disappear after making edits to many many records at the same time (for example copying data from one field to another for 50 records 5-10 times in a row). However, histories are not actually deleted. When this happens I can go to another record but can't go to another tab or create activites. All the histories reappear after closing and reopening ACT.

 

This is the only way I have been able to consistently reproduce this problem. I am the only user in the database that makes modifications to multiple records at a time. Other users have seen this issue without updating mutiple records at a time, but we weren't able to reproduce it. I was also able to reproduce this issue with the ACT11Demo database along with an error message that appears sometimes (The ACT Application has encountered an error. Please shut down the application). I haven't seen this error message on our database.

 

We are using ACT! by Sage Premium 2009 (11.0) Version 11.0.0.367. We plan to upgrade to 11.1 soon.

 

Anyone else experiencing this problem?

 

Thanks for you help!
-Sudha

Moderator
Posts: 4,395
Country: USA

Re: Histories disappear

I wasn't able to reproduce in 11.1.  How big is your database?  Try running a reindex from Tools > Database Maintenance > Check and Repair.
Copper Contributor
Posts: 60
Country: United States

Re: Histories disappear

Sorry for the late response, I wanted to update to ACT version 11.1 hotfix 1 before testing this again. The fields that I am trying to copy the data from and to have generate history enabled (Under Edit Fields). I am not sure if this has anything to do with the issue, but I was able to reproduce this on both our database and the ACT11Demo database.

 

Here are the specs of our database:

ADF file size - 434 MB

ALF file size - 768 KB

Backup file size (including attachments) - 1.32 GB

We run scheduled maintenance every night and those have been completing successfully according to the logs.

 

 

I have noticed another strange issue kind of related to the issue above as either one occurs when I edit multiple contacts at the same time. This happens most of the time and again was seen on the Demo database as well. It is difficult to explain, so I will describe it in steps:

1. Create a lookup of 200 contact records. (I used the demo database.)

2. Go to the Contact Detail view of the 30th contact and then go back to the Contact List view.

3. Copy values in field A to field B. Fields A and B should have generate history enabled. Also, Contact and Company fields should have generate history enabled. (I used the Country field and the User 1 field for A and B.)

4. After the copying is complete go to the contact detail view of the first contact and browse to the next contact by using the Forward arrow on the toolbar. (The top portion of the Contact detail view does not change).

5. Click on the forward button a few more times, but the top portion of the contact detail view still does not change.

6. Close Act and then reopen.

7. Go to the same lookup that was created before. Notice that the contact name or company name is copied on to the records that were viewed on steps 4 and 5. This can also be viewed in the history tab.

 

Sometimes it is necessary to repeat steps 1 to 5 about 2 - 4 times with different fields in order to consistently reproduce it.

 

Please let me know if anyone else is able to reproduce either of the issues above.

 

Thanks,
Sudha

 

New Member
Posts: 5
Country: United States

Re: Histories disappear

Hello,

 

Our company is also experiencing this problem.  In our case, sometimes we do a simple look up and we're scanning through our history notes (scrolling up and down), then all of a sudden, our history section under the "Regarding & Details" column would be blank instead of showing the subject line or some of the notes.  Then when we move our mouse, it will start making "error beeps".  When we try to get out of the contact list by doing another look up or even clicking on any other tabs, the software won't let us.  Eventually we would have to close out ACT, open it again, and everything works again.

 

This will happen several times a day.

 

Currently we are using

 

ACT! by Sage Premium 2009 (11.0) Version 11.1.183.0, Hotfix 1. 

Microsoft Office Outlook 2003 (11.8217.8221) SP3

Microsoft Office 2003 (11.8237.8221) SP3

Operating System Microsoft Windows XP Professional Version 2002, Service Pack 3. 

 

I'm using a Dell Optiplex 755, Intel Pentium Dual CPU E2220 @ 2.4 GHZ, with 1.96 GB of RAM. 

 

The other systems that are affected are using similar hardware and the same software.

 

We have addressed this issue with ACT!'s Customer Support and they don't know how to solve it (or so I've been told).

 

I've also notice when the problem occurs, we can't even go into our Tools tab because it will freeze all of our functions.  Any help is appreciated.

 

- John W.

New Member
Posts: 6
Country: United States

Re: Histories disappear // contact list disappears

I cannot contact support as I'm a trial user but here's what happens to me and how I get around shutting down the software and restarting --

 

1. Click Companies

2. Click one contact in the list of a company

3. Above Contact Detail system reads 1 OF 1

4. Click Contact List or Contacts and Contact List and you only see the ONE entry.  {what a pain!}

 

Work around to avoid exiting/re-entering this software --

 

5. Click NEW Contact.

 

This will make ACT! lose it's dementia and realize I have 400+ records.

 

To those out there that would suggest Tools - Database - Repair / Reindex, please add an option to send insults to the programmer who botched this part of the code.

 

Thanks!

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Histories disappear // contact list disappears

Hello majkboy,

Welcome to the ACT! Online Community. To clarify the process you described in your post, ACT! is working as designed. When you click a contact link from a Company list (or any other list view), you are doing a lookup of that 1 contact. The number displayed in the upper left is the number of contacts in your active lookup. To get the full contact list back, you would go to Lookup/All Contacts...you do not need to create a new contact.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 5
Country: United States

Re: Histories disappear

[ Edited ]

I must not understand how the last two posts have anything to do with our ACT! problem being resolved.  Both Sudha and I are having similiar problems with our histories disappearing, and the last poster has a completely different problem.  Yet of course when he posts his "problem", that's when a moderator answers.  And by the way, when I have this error/bug, I can't even click on the Tools tab to get to the Repair option. 

 

John

Message Edited by JWHorizons on 06-19-2009 02:50 PM
Copper Contributor
Posts: 60
Country: United States

Re: Histories disappear

I agree with John - the issue posted by majkboy is a completely different from the initial post.

 

We still see histories disappearing (the regarding & details field) from time to time, atleast a 2/3 times a week on different machines and different users. The only workaround (I know of so far) is to restart ACT! and everything then works fine.

 

-Sudha

New Member
Posts: 6
Country: United States

Re: Histories disappear // contact list disappears

Thanks for the immediate response.  I'll give that a try!

 

BTW, my apologies if I posted this in the wrong section.  When I searched, this is the section I got and it seemed related.

Bronze Elite Contributor
Posts: 2,547
Country: New_Zealand

Re: Histories disappear // contact list disappears

In working with ACT! 11.0 everyday I sometimes see this type of behaviour, however I have not seen a situation in which there is a permanent loss or misalignment, for want of a better descriptive, of the data in History or fields. It does appear to occur at times of mass changes or manipulation of data through lookups and mail merge operations.

 

A SQL database by nature, does not write changes to the data file (adf in the case of ACT!) immediately. There is a delay before the changed information is commited to the data file from the transaction log file (alf in the case of ACT!). There are a number of reasons why the delay to committing the information varies. One of the factors is the nature of the design of the application, in this case ACT!, as to the process that determines when the commit action takes place. Other database applications using SQL as the backend database may not exhibit this behaviour and this is probably a factor of the application design. So overall while I can concur that I have seen the type of behaviour that contributors are seeing, I have yet to see incorrect data assignment after either refresh, running database maintenance or close the database and application and re-open.

 

One factor that is sometimes overlooked is the variation of intensity and type of activity different users are performing in working with ACT!. In our work we find that there is a correlation with 'power users' alerting us to this type of phenomena.

 

Has anybody detected a situation in which data was incorrectly assigned permanently?

Graeme Leo
Xact Software - consultants and developers
Follow us on Twitter and check out our Blog