Community
Showing results for 
Search instead for 
Do you mean 
Reply

Google Contact Sync Error - ConsumerKey and ConsumerSecret must be provided to use GOAuthRequestFactory

Copper Contributor
Posts: 116
Country: Canada

Google Contact Sync Error - ConsumerKey and ConsumerSecret must be provided to use GOAuthRequestFactory

I'm using Act version 16 wtih Google Integration.

I've noticed that I'm getting errors when running the integration sync and the error is related to sychronizing contacts.

What is the solution to this?  See attached.

 

google sync error1.JPG

google sync error2.JPG

Moderator
Posts: 720
Country: USA

Re: Google Contact Sync Error - ConsumerKey and ConsumerSecret must be provided to use GOAuthRequestFactory

This error has happened before and currently there's no known resolution for it. Does your Google account happen to have two-step verification on it?

Elise O'Pry
Swiftpage
Visit our knowledgebase at http://kb.act.com
Copper Contributor
Posts: 116
Country: Canada

Re: Google Contact Sync Error - ConsumerKey and ConsumerSecret must be provided to use GOAuthRequestFactory

I don't recall Elise. Where do I check that and what setting are you recommending? I use a Google Apps gmail address.
Copper Contributor
Posts: 116
Country: Canada

Re: Google Contact Sync Error - ConsumerKey and ConsumerSecret must be provided to use GOAuthRequestFactory

Is this issue still being looked at by Swiftpage?

The problem still exists and it makes me wonder if the Google integration with ACT is actually working.  It's certainly not reliable as it is, and I'm having to constantly double check ACT records to see if email history is even being recorded.  Often it isn't.  The automatic progress to run Google Integration doesn't always seem to be working.