Community
Showing results for 
Search instead for 
Do you mean 
Reply

Format number without commas

Accepted Solution Solved
Copper Contributor
Posts: 61
Country: USA
Accepted Solution

Format number without commas

In order to sort by street, and then by street number, I have separated the two and made the street number a "number" field.  But it appears and is printed with commas, which I do not want.  Is there a way to format it without commas?

 

Thanks,

Paul


Accepted Solutions
Solution
Accepted by topic author stillstonevisions
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 61
Country: USA

Re: Format number without commas

Yes, now I'm able to get what I wanted.  Thanks for the patience!

View solution in original post


All Replies
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Format number without commas

[ Edited ]

Hello Paul,
Unfortunately, with a Number field, you cannot change the screen display to remove the commas. You would have to use a Character field for this. As for printing, you can have it display without commas in an ACT! report or export to Excel by changing the format to General.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 61
Country: USA

Re: Format number without commas

Thanks for the reply.

 

There is no "General" number format in Act 2013....only "Decimal" and "Number" and they both display with formatting inappropriate for a street number.  I can't use "Character" because it won't allow numeric sorting.

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Format number without commas

To clarify, the "General" format is relative to ACT! reports and Excel (for printing), not field data type. And yes, unfortunately a character field will sort based on the first character in the string.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 61
Country: USA

Re: Format number without commas

Thank you for the clarification.  However, I have so far been unable to find a place in the report generator to modify the field's appearance.  Can you offer a bit more direction?

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Format number without commas

Sure. Go to Reports > Edit Template and open your report template. In the report designer, right-click on the number field (not the field label) and select Properties. Under the Format tab, select General. This will display the number without commas on the report.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 61
Country: USA

Re: Format number without commas

When I right-click on my field name (CSmiley Frustratedtreet Number), Properties is not one of the options.  The popup menu reads "Undo, Paste, Select All, Hide Grid, Snap to Grid, Define Sections, Define Filters, Edit Report Scripts"

 

The same field appears twice in the report, which is a slight modification of Task List.rep, but the result is the same for both locations when I right-click.

 

Thanks,

Paul

Platinum Elite Contributor
Posts: 6,669
Country: USA

Re: Format number without commas

Try left clicking on the field first and then right clicking. those are the properties for the section of the report not the field..

 

There is a third party book with comprehensive training information on the ACT! reports, here is the link.

https://www.packtpub.com/sage-act-2011-dashboard-and-report-cookbook/book

 

Full disclusure I wrote the reports chapters of the book.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Copper Contributor
Posts: 61
Country: USA

Re: Format number without commas

Thanks for the book recommendation.

 

When I left click on the field in question, nothing happens.  It does not select.  It is light blue in color and does not change.  If I left-click on other fields, such as [My:Address] in the upper-right-hand corner, a frame appears around it. And I can right-click on that field and get the properties, but not on the one I need it for.

 

Oh, I think I just found the problem.  In the "Properties" table to the right, the header is set to "Section 2-Footer".  If I change that to "StreetNumber1 Field", then the field becomes available for selection.

Solution
Accepted by topic author stillstonevisions
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 61
Country: USA

Re: Format number without commas

Yes, now I'm able to get what I wanted.  Thanks for the patience!