Community
Showing results for 
Search instead for 
Do you mean 
Reply

Failed to restore remote database. Failed to open a connection to the database.

Accepted Solution Solved
Copper Contributor
Posts: 16
Country: United States
Accepted Solution

Failed to restore remote database. Failed to open a connection to the database.

I am trying to set up a Synchronization for the first time.

 

I am having this problem with Act 10.0.3.182.  I have updated Sync Services, as well.  I am trying to run across a local area network in a domain for the first time and set up two remote databases on laptops to synchronize with a desktop.  One laptop is Vista, the other machines are XP Pro, if it matters.  I have also opened permissions on the host directory.

 

 

 

Accepted Solutions
Solution
Accepted by topic author bcoddy
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 16
Country: United States

Re: Failed to restore remote database. Failed to open a connection to the database.

OK - I'm a dork.  I went back thru KB 13657.  In running actdiag, the RDB was listed as "RECOVE".  I deleted as suggested, restored and it worked!

Thanks for the suggestions.  Now to the next machine.

View solution in original post


All Replies
Copper Elite Contributor
Posts: 127
Country: Australia

Re: Failed to restore remote database. Failed to open a connection to the database.

Have you checked the steps in the ACT! KB article 13657?
Regards
Neil Gilford
ACT! Certified Consultant
Gilford Computer Solutions
neil@gilford.com.au
Copper Contributor
Posts: 16
Country: United States

Re: Failed to restore remote database. Failed to open a connection to the database.

No, I have not.  Thanks for pointing that out.  It does seem to be for ACT 2005, but valid for 2008 as well?  I will try tomorrow when back at the site.
Copper Contributor
Posts: 16
Country: United States

Re: Failed to restore remote database. Failed to open a connection to the database.

I have tested everything except selective start-up, and it is all as it should be.  Still no success.  Any other suggestions?
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Failed to restore remote database. Failed to open a connection to the database.

Also make sure that the port that ACT! is syncing throught (by default TCP port 65100) is open and listening on the server and that the laptops can get through that port to the host.  I would advise adding the port as an exception to the firewall.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Solution
Accepted by topic author bcoddy
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 16
Country: United States

Re: Failed to restore remote database. Failed to open a connection to the database.

OK - I'm a dork.  I went back thru KB 13657.  In running actdiag, the RDB was listed as "RECOVE".  I deleted as suggested, restored and it worked!

Thanks for the suggestions.  Now to the next machine.

Moderator
Posts: 4,395
Country: USA

Re: Failed to restore remote database. Failed to open a connection to the database.

I've been in the same boat before... Its always the little things that we skip over.  Thanks for keeping us informed on the solution.

New Member
Posts: 1
Country: Canada

Re: Failed to restore remote database. Failed to open a connection to the database.

Hi folks,

 

New user to act. 

 

Had a company replace a computer. They wanted to save us time so they installed Act Premium. They said they had looked at the current version on the 'old' computer.

 

I received the computer, unpacked & restored the database. Said it need to upgrade the database for that version. No other option to opt out so I did it.

Opened Act. Looked wonderful - everything was there.

Went to sync and it said the remote database was a different version.

I checked Act and sure enough, it was v18sp2.  We are on 18.1.103.0 ! Smiley Sad

Used the remove program feature and removed the sp2 version.

Delete the database files

 

Copied the packed .rdb file over again.

 

Installed the proper version of act

Tried to do an unpack & restore, but it says "failed to restore remote database. Failed to open a connection to the database"

 

So I looked at kb 13657, but when I'm in the actdiag, I can see the original database no problem yet I can't choose the Action menu.

 

I get the error "Unable to cast object of type 'System.DBNull' to type 'system.string.'

 

I can't seem to delete the database for which I had already removed myself (ok...so that may be a mistake on my part).


But any other suggestions?

 

I tried looking up that SSMS, but I couldn't see any database listed anywhere.

 

Any help/direction would be great. Otherwise I'll be in the office tomorrow morning hoping Act support can help me.

 

Cheers,
Brian

 

Employee
Posts: 37
Country: United_Kingdom

Re: Failed to restore remote database. Failed to open a connection to the database.

[ Edited ]

Hi Brian,

 

You mentioned that you deleted the database files.  Did you stop SQL (services.msc) first, or attempt to detach from SQL in actdiag before deletion?  

 

This will leave you with the issue of being unable to delete an already deleted database from the list in actdiag. 

 

If my understanding of this is correct (please inform me if I have misunderstood), follow the steps below to delete from actdiag:

 

  1. In Act, create a new database, called test. Username Admin, no password.  For ease of location, place this test database on the desktop
  2. Stop SQL Server (ACT7) through services.msc
  3. Copy the database files (ADF and ALF) for database 'test' and paste into the location listed in Actdiag for the affected database
  4. Rename the database files to match the name of the affected database listed in Actdiag
  5. Start SQL Server (ACT7) through services.msc
  6. Delete the database from actdiag
  7. Detach the test database from SQL in actdiag and delete from desktop.

After these steps, please discard the existing .RDB file and create a new remote to unpack.

 

Thanks