Community
Showing results for 
Search instead for 
Do you mean 
Reply

Failed to create Remote Database

New Member
Posts: 7
Country: USA

Failed to create Remote Database

Hi,

 

I'm using Act premium for the web 2010 and I'm having trouble creating a remote database.  I've tried going, file --> new database and creating a remote database, that works.  When creating a rdb from the existing database, I get "Invalid column name 'PICKLISTITEMID'. "

 

Can anyone help me out?  I've tried rebuilding the database, detaching the database and deleting all syncs.  I've had no luck.

 

Bob

Employee
Posts: 1,163
Country: USA

Re: Failed to create Remote Database

Hello Bob,

 

Welcome to the Act online community.

 

It sounds like your issue may be related to sync sets and/or users. Try removing your sync sets and creating one with a single user, if that fails, try with another user. If you don't want to make these changes in your production DB you can make a backup and restore it and test in that one.

Matthew Wood
Act! SDK Support
Community Moderator
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Failed to create Remote Database

Hello Bob,

Welcome to the ACT! Online Community. In regards to this issue, we have seen we this can be used by a particular user record. Try this:

Create a new sync set and make it for All Users. Create new remote using this sync set and see if you get the error. If you do, then modify the sync set to only include 1 or 2 users, then create a new remote. If you still get the error, then try again with different users for the sync set until you can narrow down which user account(s) are causing the issue. Once you find out, you will need to delete the user(s) and create new user logins for them. If you have a lot of users, then this may take some.

 

Also, you mentioned that you tried "rebuilding the database" - does this mean that you ran the rebuilds for Security and  Sync Sets? This would be done through ACT! Diagnostics. If you have not, then you may want try do this before testing the users.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 7
Country: USA

Re: Failed to create Remote Database

Hi Guys,

 

Sorry, by rebuilding the database, I meant actdiag, verify database.

 

 I tried the suggestions you guys made quite a few times.  It wasn't until I started documenting my steps to ask for more help that I got it to work.  

 

So

1.  Thank you very very very very much for your help ;  I tried so many things to make this work including adding a picklistitemid in a couple of the tables!!

2.  Here's the list of steps I took that helped me solve my problem. I hope it will be of help to someone if they come across the same problem.

 

Steps I took to resolving (in order): 

 

Deleted all the syncs, disabled synchronization, added a new user, closed down act, started up actdiag, clicked the appropriate db, rebuilt the database security, rebuilt the sync objects, closed the actdiag, restarted act and logged in as new user, deleted original user, exited act, started up actdiag, clicked the appropriate db, rebuilt the database security, rebuilt the sync objects, closed actdiag. (Rebooted because my system crashed) Restarted act (no login request), Enabled synchronization, Created a sync set for selected user (only one user available), attempted to create a remote db using the default options and the sync I just created and it worked!  Wow, I'm amazed.  I tried these steps a few times and when I started over and went to document it, it worked.  When deleting a user, the application asked me if I wanted to transfer somethign to another user.  The very last time I tried, I clicked No.  I wonder if that's what was needed to make it work.

 

Thanks again for the help, I really appreciate it!

 

Bob

New Member
Posts: 7
Country: USA

Re: Failed to create Remote Database

Sorry guys, those steps didn't actually work.  It looks like after taking all those steps, ACT created a new database with no companies and contacts and I was able to create a remote db from that.  It wasn't until I went to lookup data that I realized I had no data to look at.

 

Anyways, I restored a backup, and I'm still at the same problem.  Any other suggestions?

New Member
Posts: 7
Country: USA

Re: Failed to create Remote Database

If I create a new database and export all my data from this database to the new one, the new database works and accomplishes everything I need.  The drawback to this solution is that I have to manually recreate all defined fields that we have previously defined and map it during the export process.

 

I also tried to File --> Save Copy As.. and I get the PICKLISTITEMID error here as well.

 

The database failed to copy due to the following reason:

Invalid column name 'PICKLISTITEMID'.

PRC_UTIL_COPYDATA_CONTENT: SYNC INSERT INTO TABLE

 

I hope this may be of help in finding a solution.

Bronze Contributor
Posts: 955
Country: Australia

Re: Failed to create Remote Database

You might if you are using Vista or windows 7 from the desktop click on the ACT icon right click and "run as administrator" as I have seen this when trying to create remote databases

Paul Buchtmann
pbuchtmann@ozemail.com.au Australia
Australia's First ACT Consultant (1989)

FREE Record History to change default to Call or To-Do for ACT! 2010-2012 versions. Custom versions also available.
New Member
Posts: 7
Country: USA

Re: Failed to create Remote Database

I'm using windows XP and it's running in administrator mode already. 

 

I found a workaround. Bif of a pain in the butt, but it worked.

 

I saved a copy of the database as a structure (no records) and then I exported directly into that file.  When I opened the new database, all my contacts, calendars, and companies where there.  I was just missing my attachments.  Luckily that wasn't a big issue.  I must say, once this program is up and running it's pretty good.  Otherwise, you can easily loose a lot of time trying to get it to work the way you need it to.

 

Thanks everyone for the help.  I hope this work around helps anyone that may experience the same problem as I did.

 

Bob