Community
Showing results for 
Search instead for 
Do you mean 
Reply

Error message when trying to merge to MS Word 2013

Astute Commentator
Posts: 54
Country: USA

Error message when trying to merge to MS Word 2013

We're getting a nasty error message when ACT attempts to merge to Word 2013.  I found similar error messages on the forum, but not this specific one, so I did a new post. 

 

Unable to cast COM object of type 'System._ComObject' to interface type 'Microsoft.Office.Interop.Word.Application'.
This operation failed because the QueryInterface call on the COM component for the interface with IID '(00020970-0000-0000-C000-0000000000046)' failed due to the following error: Error loading type library/DLL. (Exception from HRESULT: 0x80029C4A (TYPE_E_CANTLOADLIBRARY).

 

This is similar to another error message mentioned here:  https://help.act.com/hc/en-us/articles/360024421353 

 

If you look at the text of my error, this is a different error message than the more common "The RPC server is unavailable" error message for which there is a registry fix.  The registry fix has worked for me on a different machine in the past.

 

In this case, I tried that registry fix and it did not work.

 

Thank you very much for your help!

 

 

- Version of Act! you are using:

On Windows 10 workstations:  Act Premium 21.1.187.0 , Update 4

On Windows 2016 Server:  Act Premium Web 21.1.187.0 , Update 4

 

- If the issue involves Microsoft Office (Outlook, Word , Excel), state the version of Office you are using

Office 2013

 

- Is your database on your local machine (private database) or is it being shared from a server (shared database)?

Shared from a server.

 

- Operating system you have Act! installed on (i.e., Windows 7, Windows 8)

Windows 10 on the workstations.  Windows Server 2016 on the Act server.

 

- As much detail regarding the question or issue as you can provide:

 

 

 

 

Nickel Super Contributor
Posts: 481
Country: United_Kingdom

Re: Error message when trying to merge to MS Word 2013

You could re-register the Redemption.dll in the Act! folder , Close All applications open a cmd prompt, type cd C:\Program Files (x86)\Act\Act for Windows and then press the enter key (this should be where act! is installed) then type in regsvr32 redemption.dll and hit the enter key again, you should get a message stating it has registered OK. Test doing a merge. If it still fails try doing a repair on office, reboot your machine and then try a merge.again. 

Astute Commentator
Posts: 54
Country: USA

Re: Error message when trying to merge to MS Word 2013

[ Edited ]

Thank you very much for the reply.  The user says that the error message went away and ACT is merging successfully now, but I will hang on to your recommendation in case it comes back.