Community
Showing results for 
Search instead for 
Do you mean 
Reply

Error - The impersonation user account does not have access to the database you selected.

New Member
Posts: 1
Country: Romania

Error - The impersonation user account does not have access to the database you selected.

Hello.

 

Just installed Act Premium (web) v16 with web acces and, after following all steps in the guide, I still have the error, when trying to link the database with web tool:

 

"The impersonation user account does not have access to the database you selected."

 

I suspect some additional steps required for Windows Server 2012 R2 or IIS 8, but I don't know which...

 

Apparently, the application works fine, even with web clients, but the error persists.

 

Any hint, please?

Copper Contributor
Posts: 45
Country: USA

Re: Error - The impersonation user account does not have access to the database you selected.

Hi, I'm no expert but I leave some Ideas

This message will result when the impersonation user account does not have access to program files and folders or registry permissions required to run ACT! Premium for Web. The following is a list of required access rights:

Impersonating on single-server configurations:
The impersonation user account you create must have the following attributes:

  • Be a local Windows administrator on the Web server.
  • Have permission to access all ACT! Premium for Web and database supplemental files on the server.

Best Regards,

Everyday I learn something new
New Member
Posts: 9
Country: Canada

Re: Error - The impersonation user account does not have access to the database you selected.

"This error may happen in Windows Server 2012 for any version prior to Server 2012 support. The error may be false, simply test the APFW site for functionality after getting this message."

 

With Server 2012 R2 there isn't any extra steps. Test the APFW application pool and VD manually and as long as everything works there are no issues running. From what the tech told me this is not a problem with compatibility, but the development team has it in their hands and will patch out the error message.

Mike Johnston, ACC
www.keystroke.ca
Copper Contributor
Posts: 116
Country: Canada

Re: Error - The impersonation user account does not have access to the database you selected.

Is this still an issue?

 

New server setup running Windows Server 2016 and ACT Premium v20.

I've setup a Domain account as the ACT Impersonation account.

On the Web Site Administration screen I can't get the TEST DB button to work without an error.  The Windows account I'm using is a domain user that is a member of a group which is in the Local Administrators group on the server.

Testing the website, for example, http://<server IP Address>/APFW/contacts/contactDetail.aspx

the page does load as expected.

 

Would like to hear something from Swiftpage on this please.

 

 

ACTImpersonator.jpg

Bronze Elite Contributor
Posts: 1,427
Country: United_Kingdom

Re: Error - The impersonation user account does not have access to the database you selected.

Try creating a LOCAL user account on the server with administration rights. Use that account, it should resolve the issue.

 

 

Administrator
Posts: 411
Country: United_Kingdom

Re: Error - The impersonation user account does not have access to the database you selected.

Exactly as Chip has said - the Act! impersonation account requires local administrative rights to the machine hosting the database. This is sometimes not possible to do if the host machine is a domain controller, which is why we don't recommend using a domain controller as the host for an APFW database.

 

Essentially so long as the account has full control rights on the database file structure, the APFW installation folder, registry access and any other supplemental file location permissions you shouldn't experience issues - but you may get error messages during set up if they aren't a full local admin.

 

 

Copper Contributor
Posts: 116
Country: Canada

Re: Error - The impersonation user account does not have access to the database you selected.

I've created a local user, ACTImpersonator, on the ACT Server as suggested.

But for whatever reason, even after I put that user in the Administrators group and restarted the server, the Web Site Administration screen still will not allow me to add this local user.  With the new Local User I can't even add the user credentials on that tab.  I've checked and reset the password as well, so the error is not a result of a typo.

 

localuser.jpg

 

So I had to try the Domain account again.  The Test on the User Account tab was successful.

Then I tried the TEST DB button again just for kicks, and all three of the databases I've added so far all completed successfully.

So strange!  I'm happy it's working right but but have no idea why it's working today and not yesterday.

 

Bronze Elite Contributor
Posts: 1,427
Country: United_Kingdom

Re: Error - The impersonation user account does not have access to the database you selected.

When you put in the User change the Account to the local machine, it will default to the Domain account so you have to change it to the local machine.

Copper Contributor
Posts: 116
Country: Canada

Re: Error - The impersonation user account does not have access to the database you selected.

Of course.  I was already changing the Windows Domain dropdown choice between our Domain name and the Local Name of the ACT Server.  This dialog is not accepting any Local Admin users I created on the ACT Server.  If I change the Windows Domain choice to our company Domain and put a Domain user ID and password in it works.

 

edituser.jpg