Community
Showing results for 
Search instead for 
Do you mean 
Reply

During Restore, cannot select Share - Act! 2009 Premium Running on Windows SBS 2011 Essentials

Accepted Solution Solved
New Member
Posts: 4
Country: USA
Accepted Solution

During Restore, cannot select Share - Act! 2009 Premium Running on Windows SBS 2011 Essentials

A client just moved to a Windows SBS 2011 Essentials server.  They successfully loaded ACT! 2009 Premium, and are able to restore a database from the old server.

 

The problem is the "Share" option is not available during the restore, and after the database is restored, the "Share" option under Database Maintenance is grayed out.

 

If you click to create a new database, again, the option to share is not available.

 

I suspect the issue has to do with SBS 2011 Essentials (which I believe is based on Windows 2008 R2), but am not sure what.

 

Any assistance will be greatly appreciated.

 

Thanks


Accepted Solutions
Solution
Accepted by topic author RLindenau
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,669
Country: USA

Re: During Restore, cannot select Share - Act! 2009 Premium Running on Windows SBS 2011 Essentials

You need to open the ACT! program with the Run as Administrator option.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129

View solution in original post


All Replies
Solution
Accepted by topic author RLindenau
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,669
Country: USA

Re: During Restore, cannot select Share - Act! 2009 Premium Running on Windows SBS 2011 Essentials

You need to open the ACT! program with the Run as Administrator option.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
New Member
Posts: 4
Country: USA

Re: During Restore, cannot select Share - Act! 2009 Premium Running on Windows SBS 2011 Essentials

Thanks - that got us beyond that issue.  I often tell people they sometimes have to run programs as "Administrator", but did not expect it to apply in this case.

 

The database is now shared, but I still cannot open it from an XP workstation.  I get the message that "the database... could not be accessed" ... check your network connection...

 

The XP computer was able to access the files from the older server (Windows 2003) with no problem - we are on a new domain, if that means anything to ACT!

Platinum Elite Contributor
Posts: 6,669
Country: USA

Re: During Restore, cannot select Share - Act! 2009 Premium Running on Windows SBS 2011 Essentials

On the server, rename the pad file and open (as administrator) using the ADF file. that should resolve the situation with the workstations.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
New Member
Posts: 4
Country: USA

Re: During Restore, cannot select Share - Act! 2009 Premium Running on Windows SBS 2011 Essentials

When I tried this it told me the file was in use, no where I know about.  I am restarting the server to see if that gets me around that message.

 

While trying to solve the workstation issue, one of the things I did was turn the firewall off on the server.  This allowed the workstation to access the database.  My problem is knowing what port needs to be open.  When I run ACTDIAG on the server it tell me it is listening on port 53835, not a port I can open, so I am not sure which I need to do.  I am looking as some discussions about opening ports for SQL - any suggestions would be gratefully appreciated.

New Member
Posts: 4
Country: USA

Re: During Restore, cannot select Share - Act! 2009 Premium Running on Windows SBS 2011 Essentials

Roy,

 

It turned out to be a Firewall issue.  I opened the ports in the firewall as described the the following link and was then able to access the ACT! Database from the XP workstation (http://support.microsoft.com/kb/968872/en-us?p=1).

 

Thanks for your timely assistance.

 

Ron