Community
Showing results for 
Search instead for 
Do you mean 
Reply

Database lost - urgent

New Member
Posts: 16
Country: United_Kingdom

Database lost - urgent

A few days ago I had a catastrophe in that my hard drive decided to die unexpectantly. I have now purchased a new hard drive, installed windows  and am trying to reconfigure everything.  I did not do an official backup of my ACT databases however I did manually copy the database files over to a USB flash drives a few weeks ago.  I have the  ADF, alf ,PAD as well as the database folder.  Logic tells me that I should be able to restore my ACT database from this even though I have not done a backup the official way?  I am using Sage act premium 2011 Hot Fix 4

The problem is that when I try to open the PAD or ADF file it does not work.  As suggested when I try to open the ADF file I get the following message:

"This database cannot be opened because the SQLServer version of this database cannot be identifed"

 

I have tried looking at guides and as suggested delted the PAD file and tried opening with the ADF file but I still get the above message.  I also have the latest edition for my program and according to services.msc "SQL server (ACT7) is an active service."  There is nothing wrong with the SQL server on the new install as I am able to create a new database etc, but I just can't open the old one.


I am really at a loss as to how I can get my database up and running again?  I am extremely anxious as the database contains nearly 6 months of work and extremely important customer contact details etc.  If anyone knows how I could get this working I would be extremely grateful. If there are no solutions I would even be willing to pay someone to get this working as I am extremely desperate.

 

There is nothing wrong with my SQL intall as I can create new databases etc no problem. I have tried removing ACT reinstalling as well as creating manual SQL instances however nothing works.  I have also tried the latest trial edition of ACT.  Please hlep as I need this fixed urgently.

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Database lost - urgent

It may be that the database files are corrupted and you will need to contact our Database Services group, or an ACT! Certified Consultant.

 

But here is another step to attempt: using the new Actdiag tool, attach the ADF file to SQL without the log file.  This will create a new log file.

To do this, you will want to make a copy of the ADF file and rename it to a new name.  Then use the Actdiag utility to Attach Database with Missing Log File.  The instructions for this are in the following article: KB Article 27607

 

Note: If you haven't already, copy the files from the USB drive and place them in a folder on the local hard drive before attempting to open.  There could be an issue accessing the files on the USB drive.

Greg Martin
Sage