Community
Showing results for 
Search instead for 
Do you mean 
Reply

Citrix XenDesktop

New Member
Posts: 1
Country: United_Kingdom

Re: Citrix XenDesktop

Hello,

 

We are experiencing the same problem with Act Premium v16 installed on a Windows Server 2012 RDS Session Host configured as a XenApp 7.6 server.

 

When a user launches a desktop session from the server and launches the "Act! Premium" desktop shortcut, they get the error message that other users have also reported in this thread: "A service required to use Act! is not currently running. Please log on to the computer as an Administrator and start the service manually".

 

I can start the Protexis Licensing V2 service as an administrator from services.msc but upon launching the shortcut again, the service stops and the application displays the same error message before exiting.

 

If anyone has a solution I'd be greatful to hear it!

 

Thanks

Copper Super Contributor
Posts: 33
Country: Germany

Re: Citrix XenDesktop

Hello,

 

I got the same issues with Windows 2012 R2 and Act! 17 as I try to provide act as an app in citrix.

 

DSCFL talked about a script which could solve the issue but there is no further information.

 

Is there a workaround or a fix out there to get this running?

 

I would appreciate any help with this.

Copper Contributor
Posts: 6
Country: USA

Re: Citrix XenDesktop

 

I had to mess with this, and was able to get the Protexis Licensing Service happy.  if you look in services you will see that you can start it, then it will stop after ACT opens and cause the issue.  

 

If you are using Sage ACT! 2012 or above, after the Licensing Service file has installed, please follow these additional steps:

  1. Navigate to and open the appropriate folder:
    • 32-bit OS: C:\Program Files\Common Files\Protexis\License Service
    • 64-bit OS: C:\Program Files (x86)\Common Files\Protexis\License Service
  2. Right-click on the PSIKey_2.dll file, select Rename, and rename it to PSIKey_3.dll.
  3. Restart the Protexis Licensing V2 service from the Services console.

http://kb.act.com/app/answers/detail/a_id/23027/~/how-do-i-uninstall-and-reinstall-the-protexis-lice...

Copper Super Contributor
Posts: 33
Country: Germany

Re: Citrix XenDesktop

Hi tmallon,

 

thank for the reply.

 

But I think this won’t fix the issue at the Terminal\citrix server.

 

As the users has to do every time they login to their desktops. As the changes wouldn´t be saved and the mac always changes.

 

So I hoped somebody has me a solution without setting up personal vdisk.

Copper Contributor
Posts: 6
Country: USA

Re: Citrix XenDesktop

make the change on the PVC the Golden image.
Copper Super Contributor
Posts: 33
Country: Germany

Re: Citrix XenDesktop

Hello tmallon,

 

sorry for the late reply the costumer was busy the last two weeks.

 

your solution works fine thank you a lot.

 

you saved me there Smiley Happy

 

Best regards

 

David

New Member
Posts: 1
Country: USA

Re: Citrix XenDesktop

We are having the same issue. If you could please provide the info that would be greatly appreciated!

New Member
Posts: 1
Country: USA

Re: Citrix XenDesktop

Hello, DSCFL

 

Can you send me the steps you took to resolve this issue? I am also having this problem with ACT! 18.1 and the Protexis licensing service.


Thank you!

 

Josh

Copper Super Contributor
Posts: 33
Country: Germany

Re: Citrix XenDesktop

Hello,

 

as tmallon told me in his post before. The solution for me was to set up the protexis again.

 

Like in this KB link:

http://kb.act.com/app/answers/detail/a_id/23027/~/how-do-i-uninstall-and-reinstall-the-protexis-lice...

 

This works for me I hope it will fix your issues too.

 

Best regards

 

David

Copper Contributor
Posts: 6
Country: USA

Re: Citrix XenDesktop

Yes, sorry was out of pocket for a few days,   Follow the steps in the this link and you will be set