Community
Showing results for 
Search instead for 
Do you mean 
Reply

Cannot complete sync - Incorrect syntax error '*'

bp
New Member
Posts: 7
Country: Canada

Cannot complete sync - Incorrect syntax error '*'

Hi guys,

 

I am having issues with my remote databases synching, here is the error i get

 

Synchronization has failed. Server Error Description: Incorrect syntax near '*'. Contact your administrator for assistance. 

 

I made some changes to the layout and the define fields, but i have got rid of everything that i changed and still cannot sync. Any information on how I can fix this would be greatly appreciated.

 

Thanks

 

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Cannot complete sync - Incorrect syntax error '*'

Hello bp,
Welcome to the Sage ACT! Community. What version of ACT! are you using (from Help > About ACT!)?

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

bp
New Member
Posts: 7
Country: Canada

Re: Cannot complete sync - Incorrect syntax error '*'

ACT! by Sage Premium 2009 (11.0) Version 11.1.178.0

bp
New Member
Posts: 7
Country: Canada

Re: Cannot complete sync - Incorrect syntax error '*'

Anyone have any ideas, i have been struggling with this issue for about a week now.

 

Thanks

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Cannot complete sync - Incorrect syntax error '*'

Trying running database maintenance on both the server and the remotes. From in ACT!, go to Tools > Database Maintenance > Check and Repair. Run both options.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

bp
New Member
Posts: 7
Country: Canada

Re: Cannot complete sync - Incorrect syntax error '*'

Yah the database repairs and reindexing were among the first things i tried 

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Cannot complete sync - Incorrect syntax error '*'

Have you tested creating a new remote database to see if it will synchronize. It may be the new fields/changes you created and removed are causing the problem.

Note: The changes made to the database would be queued as 'adds' to the individual remotes. Deleting the fields/changes would not remove the 'adds', but would add 'deletes' to the list of changes to make to the remotes.
Greg Martin
Sage
bp
New Member
Posts: 7
Country: Canada

Re: Cannot complete sync - Incorrect syntax error '*'

Yes i have created a new rdb and i  imagine it is the new fields that i created that are causing the issues. I have removed the fields on the publisher db that i added and then tried to sync but still no luck. Do you know of any way that i can get passed this issue or what to do?

 

THanks for your help!

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: Cannot complete sync - Incorrect syntax error '*'

At this point I believe creating new remotes will be the solution.

While you can export the contact changes from the old remotes to the new ones, that could also present a problem with the amount of changes.

It is recommended that you create a backup of the remote(s) and restore it on the server > then export the changes from the remote to the main database. Then create the remotes, that way all of the changes will already be in the new remote(s).

To export changes:
In the old remote > perform Lookup > Contact Activity > date will be the date of last successful sync (or day before). Then File > Export > database to database > select 'Current Lookup'. This will reduce the amount of data being transferred.
Greg Martin
Sage
bp
New Member
Posts: 7
Country: Canada

Re: Cannot complete sync - Incorrect syntax error '*'

But when i create new remote databases im still getting the same error when i try to sync