Community
Showing results for 
Search instead for 
Do you mean 
Reply

Cannot Import a MS Excel CSV File - Help Please

New Member
Posts: 1
Country: United States

Cannot Import a MS Excel CSV File - Help Please

Using ACT! Premium ST Edition V 10.0.3.182

 

I saved my Excel spreadsheet (MS Office 2003 Pro edition) as a CSV and tried numerous times to import the data and nothing is imported into ACT!

 

The spreadhseet is one column, 850 lines, of email addresses. I mapped it but nothing seems to work. I then tried to add a second column entitled SOURCE ID. Saved it as a CSV and again, nothing was imported.

 

When I save the Excel file as a CSV I get the following message:

 

"The file contains features that are not compatible with CSV. Do you want to keep the workbook in this format?"

 

Any ideas of what I am doing wrong?

 

Thanks,

 

Ben

Nickel Contributor
Posts: 241
Country: United States

Re: Cannot Import a MS Excel CSV File - Help Please

Importing a single field will not work because it has no idea where those email addresses belong and whom they might belong to. You should include with whatever data to be import along with 1-3 'anchor fields' in your csv file, so the import process knows where the data belongs.
Platinum Elite Contributor
Posts: 6,663
Country: USA

Re: Cannot Import a MS Excel CSV File - Help Please

Most likely the duplicate checking is at least partly the cause. If nothing was imported into the dup check fields, nothing will import because blank matches blank.
Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Cannot Import a MS Excel CSV File - Help Please

I don't know why you would, but if you just want to bring in the email address into new otherwise blank records, you'd need to turn off duplicate checking - Tools | Preferences | Duplicate Checking

 

Otherwise, it will see each record as a match and either skip or overwrite (depending on merge settings) the first record