Community
Showing results for 
Search instead for 
Do you mean 
Reply

Can't access APFW since SP2

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Can't access APFW since SP2

[ Edited ]

During the install, there are about 20 errors like this - all .Net Runtime Optimisation service with different files that failed:

Event Type:	Error
Event Source:	.NET Runtime Optimization Service
Event Category:	None
Event ID:	1101
Date:		19/04/2012
Time:		20:45:12
User:		N/A
Computer:	SERVER
Description:
.NET Runtime Optimization Service (clr_optimization_v4.0.30319_32) - Failed to compile: Act.UI.Export, Version=14.1.108.0, Culture=neutral, PublicKeyToken=ebf6b2ff4d0a08aa, processorArchitecture=MSIL . Error code = 0x80070005 

 

If I try to open it in a browser (local, LAN or phone), if keeps refreshing with this URL

http://server/APFW/default.aspx?error=true

 

And if fills the event log with errors like this:

Event Type:	Error
Event Source:	AFW
Event Category:	(98)
Event ID:	0
Date:		25/04/2012
Time:		12:00:34
User:		N/A
Computer:	SERVER
Description:

SOURCE: System.Web
MESSAGE: c:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\apfw\43fd3e78\5eb1e348\App_Theme_ACT.xl-uekdl.0.cs(339): error CS0433: The type 'Infragistics.WebUI.UltraWebGrid.ClientSideEvents' exists in both 'c:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\apfw\43fd3e78\5eb1e348\assembly\dl3\79c67e21\00adff8c_9d3ccc01\Infragistics2.WebUI.UltraWebGrid.v11.1.DLL' and 'c:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\apfw\43fd3e78\5eb1e348\assembly\dl3\2465a670\001a75c7_d572c801\Infragistics2.WebUI.UltraWebGrid.v8.1.DLL'
FORM: 
QUERYSTRING: ReturnUrl=%2fAPFW
TARGETSITE: System.CodeDom.Compiler.CompilerResults Compile()
STACKTRACE:    at System.Web.Compilation.AssemblyBuilder.Compile()
   at System.Web.Compilation.BuildProvidersCompiler.PerformBuild()
   at System.Web.Compilation.ThemeDirectoryCompiler.GetThemeBuildResultType(String themeName)
   at System.Web.Compilation.ThemeDirectoryCompiler.GetThemeBuildResultType(HttpContext context, String themeName)
   at System.Web.UI.Page.InitializeThemes()
   at System.Web.UI.Page.PerformPreInit()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
   at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
   at System.Web.UI.Page.ProcessRequest()
   at System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context)
   at System.Web.UI.Page.ProcessRequest(HttpContext context)
   at ASP.default_aspx.ProcessRequest(HttpContext context)
   at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
REFERER: 

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

 

And:

Event Type:	Error
Event Source:	AFW
Event Category:	(98)
Event ID:	1
Date:		25/04/2012
Time:		12:00:34
User:		N/A
Computer:	MONTY
Description:
1:Error occured on page: System.Web Message:c:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\apfw\43fd3e78\5eb1e348\App_Theme_ACT.xl-uekdl.0.cs(339): error CS0433: The type 'Infragistics.WebUI.UltraWebGrid.ClientSideEvents' exists in both 'c:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\apfw\43fd3e78\5eb1e348\assembly\dl3\79c67e21\00adff8c_9d3ccc01\Infragistics2.WebUI.UltraWebGrid.v11.1.DLL' and 'c:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\apfw\43fd3e78\5eb1e348\assembly\dl3\2465a670\001a75c7_d572c801\Infragistics2.WebUI.UltraWebGrid.v8.1.DLL'

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

 

These repeat till I close the browser.

 

The full client runs fine on the server, across the LAN and via sync runs fine

 

Any suggestions?

Bronze Super Contributor
Posts: 1,231
Country: USA

Re: Can't access APFW since SP2

Do you have any project from www.infragistics.com already installed on this server?

 

If possible remove them before installing APFW.

 

-- Jim Durkin

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Can't access APFW since SP2

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Can't access APFW since SP2

[ Edited ]

Mike,
Have not seen this error before, but it could be .NET 4 related since that is installed with SP2. The error would seem to indicate an issue with the same file in two locations:
The type 'Infragistics.WebUI.UltraWebGrid.ClientSideEvents' exists in both

'c:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\apfw\43fd3e78\5eb1e348\assembly\dl3\79c67e21\00adff8c_9d3ccc01\Infragistics2.WebUI.UltraWebGrid.v11.1.DLL'

and

'c:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\apfw\43fd3e78\5eb1e348\assembly\dl3\2465a670\001a75c7_d572c801\Infragistics2.WebUI.UltraWebGrid.v8.1.DLL'

 

Just a guess, but you could try deleting or renaming that file from one of those locations, or if you see duplication of a number of files, then delete one of the 'apfw' folders under the 'Temporary ASP.NET Files' directory. Then reset IIS and test.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Can't access APFW since SP2

Still no go.

 

I stopped IIS

Deleted the entire APFW folder in the Temp ASP.NET files folder

Restarted IIS

Opened browser and went to the site

 

It rebuilt all the temp folders ... including the duplicates

 

Same browser URL:

http://monty/APFW/default.aspx?error=true

 

Same errors in the event log until I close the browser.

 

Any other ideas?

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Can't access APFW since SP2

What operating system and version of IIS is being used on the web server?

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Can't access APFW since SP2

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: Can't access APFW since SP2

Mike,
Not sure if this will resolve as it addresses a different issue, but take a look at the additional process we just added for IIS 6.0 in KB article 29044:
http://kb.Sagesoftwareonline.com/cgi-bin/Sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2904...

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Can't access APFW since SP2

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Can't access APFW since SP2

Brian gave me a hand with this issue here:
http://community.act.com/t5/The-Sage-ACT-Journal/Sage-ACT-Premium-Web-Configuration-SageACT/ba-p/195...

Anyway, the demo db in defaul location seems fine now

Production db in seperate virtual folder (same but requiring windows authentication) ... normal web seems ok, but mobile (/m) returns "The page cannot be found"