Community
Showing results for 
Search instead for 
Do you mean 
Reply

COM Class factory Error when launching Word, Outlook

New Member
Posts: 3
Country: Australia

COM Class factory Error when launching Word, Outlook

[ Edited ]

Hi,

 

I have a machine that gives the following error when I try to "edit template":

 

Retrieving the COM class factory for component with CLSID {00209FF-0000-0000-C000-000000000046} failed due to the following error: 80070005.

 

The computer also refuses to write email from a template... it just hangs for 20 seconds or so then nothing, no crash or error message.

 

ACT! 2009 premium, office 2k3 professional, win XP pro.

 

I suppose I should probably just uninstall/reinstall, but I'm loath to do so, as for one, ACT! is such a pain to uninstall, and the computer in question is in constant use. 

 

Does anyone have any clues on a fix for this?

 

thanks,

 

Phil

Message Edited by tripper54 on 11-06-2008 07:41 PM
Moderator
Posts: 4,395
Country: USA

Re: COM Class factory Error when launching Word, Outlook

Try doing a Detect and Repair from Word (Help -> Detect and Repair).

 

New Member
Posts: 3
Country: Australia

Re: COM Class factory Error when launching Word, Outlook

Hi David,

 

Thanks for the response. Detect and repair didn't fix the problem, however.

 

 

Any other suggestions?

 

Cheers,

 

Phil

Nickel Elite Contributor
Posts: 567
Country: USA

Re: COM Class factory Error when launching Word, Outlook

Phil,

Doing a little research on this points that this is an Access Denied error being returned by your operating system on the given template.  Here are a couple options you can try:

 

Local Security Policies

1. Start -> Control Panel -> Administrative Tools -> Local Security Policy
2. Navigate to Security\Local Policies\Security Options
a. Network Access: Let everyone permissions apply to anonymous users - Set to Enabled
c. DCOM: Machine Access Restrictions - Add Anonymous, Everyone, Interactive, Network, System with full rights options set.
d. Network Access: Let everyone permissions apply to anonymous users - Set to Enabled
e. Network Access: Sharing security model for local accounts - Set to Classic

 

The "Sharing Security model" may be the real offending item.  Setting the above should fix the problem. If not try setting the following in DCOMCNFG.

 

DCOM Configuration

1. Click Start -> Run
2. Enter DCOMCNFG and press OK. This will open the DCOMCNFG window.
3. Browse down the tree to Console Root -> Component Services -> Computers -> My Computer
4. Right click on "My Computer" and select properties
5. Select the "Default Properties" tab
  a. Enable Distributed COM on this computer - Option is checked
b. Default Authentication Level - Set to Connect
c. Default Impersonation Level - Set to Identify
6. Select the "COM Security" tab
7. Click on Access Permissions ' Edit Default
a. Add "Anonymous", "Everyone", "Interactive", "Network", "System" with Local and Remote access permissions set.
8. Click on Launch and Activation Permissions ' Edit Default
a. Add "Anonymous", "Everyone", "Interactive", "Network", "System" with Local and Remote access permissions set.
9. Click on OK
10. Close the DCOMCNFG window

 

Here is the link that I found this information for further review, or else helps to whittle down the exact issue:

 

http://www.computerperformance.co.uk/Logon/code/code_80070005.htm

 

Thanks,

-Matt

 

Matthew McFadden