Community
Showing results for 
Search instead for 
Do you mean 
Reply

After upgrade to V19 from V18 restore database error "Incorrect syntax near '-' "

New Member
Posts: 1
Country: USA

After upgrade to V19 from V18 restore database error "Incorrect syntax near '-' "

[ Edited ]

Win 10 64 bit

Act V19

Shared Database

Trying to restore a database. I have the VPN set up to the server storing the DB and I get this error after selecting the database to restore from. Just upgraded from V 18 to V 19.

 

Changed database context to 'master'.Changed database context to 'HainbuchAmerica-RDB'.
*********** Schema Update failed **************
*********** Exception message follows *********

Incorrect syntax near '-'.
Setting Database Compatibility Level...

Schema Update failed.

 

I tried renaming the path 'HainbuchAmerica-RDB' by removing the dash and replacing it with '_' and even tried renaming the file entirely.  Do I need to go on the server and rename the targeted file path? Is that going to screw up all the people that are sharing the DB currently?

Please advise

-David

Administrator
Posts: 4,024
Country: United_Kingdom

Re: After upgrade to V19 from V18 restore database error "Incorrect syntax near '-' "

Hi David,

Just to confirm, are you restoring an .rdb file using the File > Restore > Unpack and Restore Remote Database method?
If so, was the .rdb file created on a machine running Act! v19 and the same version of SQL as the machine you're restoring to? This is required for the .rdb to restore successfully.