Showing results for 
Search instead for 
Do you mean 

Act! v19 and failure to recognize the Office 64-bit interface HRESULT: 0x80040155

Copper Contributor
Posts: 53
Country: USA

Re: Act! v19 and failure to recognize the Office 64-bit interface HRESULT: 0x80040155

The answers are:
1. Yes
2. Yes
3. BIOS is LEGACY on iMAC (Retina 5K, i7, 32gb ram, Late 2014) and MacBook Pro (Retina, i7, 16gb ram, late 2013) (Both were upgraded from Windows 8.1 64-bit pro), UEFI on MacBook Pro (Retina, i7, 16gb ram, Late 2016), HP Desktop (i7, 32gb ram) (both were initially set up with Win 10 64-bit Pro), All 3 Macs run Windows 10 Pro 64bit on top of Parallels Desktop 12 Pro edition) Same problem on all 4 machines, so it isn’t clear why this has any impact.
4. Not sure there’s an advantage to the BIOS mode or the drive formatting to avail ACT! interface with Office 64-bit? Does this connection reach into the hardware that deeply?
5. The only add-on I have other than Act! is Adobe Acrobat DC
So I'm attempting to run it on both a PC and 3 Macs (2 MacBooks, 1 iMac) but the problems are the same on both platforms with no distinction between the BIOS

Thanks for looking into it.
Nickel Contributor
Posts: 597
Country: USA

Re: Act! v19 and failure to recognize the Office 64-bit interface HRESULT: 0x80040155



As for #3. I wonder how many have installed Win10 Pro. Since your issue is across multiple computers and types that is one difference you and I have.  I will not my ACC contact uses WinPro on MAC but not sure he installed Office 64bit.

If you have the time (should not take that long for basic installs), a spare hard drive.  Wipe it clean install from CD or OEM installer on hidden partition Win10 Home 64 bit and Office 365 64 bit then ACT! Prem V19 Update 4. I know you will say ACT! should but I doubt they can move that fast. Since you have Parallels on MAC it maybe even easier to just load Win10 Home and Office 64 to rule out its not Win10 Pro?

Other option maybe there are ACC users on this post with Win10 Pro that can confirm no issue with Office 64 bit.


As for #4 it was long ago when I was switching from old to new PC and maybe just a fluke. I had a heck of a time not understanding how UEFI worked when I turned it on on my older PC.  I noticed issues like your error's that I had to reinstall everything after turning on UEFI.  I know it get deep into boot sequence and MBR. I can't say my BIOS comments is certain but what I went through.

* The other reason I bring BIOS is if your not working with XLXS files larger than 2GB, then getting to know UEFI will confirm running Windows 64 bit on more than 4GB limit helps.  It also helps support drives larger than 1TB,

More important which I learned Sunday after adding 8GB RAM more to my current 8GB for total 16GB is not over kill on my PC.  It runs better and ACT! does not lock up after heavy Import from one DB into another.  I track Task Manager and can see what SQL, ACT, and all my other Apps suck up so I was getting too close to my 8GB.


Something else that comes to mind.  Have you  turned off or lowered the Windows level for UAC?

Also Did you happen to change by doing right click on ACT icon, then again right click on the ACT Prem. item and select properties then go to Compatibility Tab and check Run this program in compatibility mode: and or even select a Win version.  Also also check down below the box Run this Program as an Admin.  If you did uncheck them Apply | OK | go back into it then click on button Run compatibility trouble shooter.  There is a Windows bug that ACT will give you in certain cases like drag drop file into ACT document Tab.  Not sure if this could be yours as well but will not hurt even if not check to ONLY make changes from the button troubleshooter.


Sorry that's all I got for now.


Copper Contributor
Posts: 53
Country: USA

Re: Act! v19 and failure to recognize the Office 64-bit interface HRESULT: 0x80040155

Sorry, JM, I didn't have the time, the new version works okay on 32-bit office, haven't even tried it on 64-bit and now may not do so. Looking at creating my own using SQL as Act! has just not delivered on the 64-bit promise. The THING that kept me with Act! since 1993 was the layout editor and the ability to use Act! to store information for my legal and accounting clients. I'm a salesman of sorts, but Act! has been used to export data to use in drafting documents and to store that data for when clients call and ask what provisions are in their legal documents. That's not rocket science, so I can get by with SQL or Access or even FileMaker to create something similar. The sauce is having something that will generate letters and envelopes through mail merge without a great deal of programming. For my legal documents, I have to rely heavily on Word's mergefields and the language you can construct using them to execute logical document assembly. Act! has been a go-to for having a database to know what is in those documents. Just wish I could maintain Word 64-bit on the same computer as Act! (not so much for Word's abilities, but because you cannot install Excel 64-bit without installing Word 64-bit. Never used the Win 10 Home, don't have a license for it. UAC is pretty low most of the time so that's not a barrier. This weekend my Windows insider edition update crashed my iMac with an unrecoverable issue so I reinstalled Win10-64 Pro and picked up the UEFI Bios rather than the legacy. No difference in how Act! behaved. One pointer, if you are using synchronization, you cannot use it unless the machine to be synced from can see the machine to be synced to, and the use of a domain on some and workgroup on others will throw that out of whack. Back up your templates for the mail-merge function, Act! doesn't transfer those to a new database should you decide to create a new one out of the orphaned remote database. Every disaster brings something to light Smiley Happy
Nickel Super Contributor
Posts: 454
Country: USA

Re: Act! v19 and failure to recognize the Office 64-bit interface HRESULT: 0x80040155

This error can occur in versions newer than ACT v19.

Verify that you don't have more than one version of MS Office installed.  If so remove the others.

You may also have to re-install ACT if the above fix doesn't resolve the issue.

Daniel Graves . . . Database-USA . . . Los Angeles . . . 818-780-3201