Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act for web 2007 premium, can't restore database to new server

New Member
Posts: 5
Country: Australia

Act for web 2007 premium, can't restore database to new server

Hi all, I'm having problems restoring my old act for web 2007 premium database.

I have replaced the server en reinstalled act on the new server. Now I have to restore the backup, that I made on the old server.

When I "restore as..."

I first select the zip file with the backup of act for web 2007 premium

I select the location to restore to

I then enter the username

I don't enter a password (There was no password)

Click ok, restore database screen comes up. This shows: "restoring database"

"Invalid user name or password. Verify the user name and password, and try again."

This username works on some other databases I've got here. I have used a password recovery tool, but the only database it does not work on is this one.

Is this because it's a web-database? Should I be using a default act iis account?

Nickel Contributor
Posts: 241
Country: United States

Re: Act for web 2007 premium, can't restore database to new server

The pword recovery tool isn't working because the database isn't attach to SQL at this point. There really aren't many way to create the particular error message your recieving. I'd login where the original dbase resides, and make sure we're entering the correct username. I'd really like to offer another solution, but for that particular error, there simply aren't many (if any) other causes.
New Member
Posts: 5
Country: Australia

Re: Act for web 2007 premium, can't restore database to new server

The old server is gone, so I don't have that option I'm afraid. Any other ideas?
New Member
Posts: 5
Country: Australia

Re: Act for web 2007 premium, can't restore database to new server

Ok, for some reason the password recovery tool could all of a sudden, access the database, so now I can get in.

 

Now I've got the following problem:

 

When I open the database file and use the old username to login (has all admin rights), it says:

 

"The database you attempted must be updated to a new version. etc... Would you like to backup this database now?"

 

When I click on Yes or No, it comes up with

 

"Act will now update the database. This process may take several minutes"

 

I then click ok. After a few seconds The first box comes up again:

 

"The database you attempted must be updated to a new version. etc... Would you like to backup this database now?"

 

When I click on Yes or No, it comes up with

 

"Act will now update the database. This process may take several minutes"

 

 

This cycle continues endless and nothing else happens...

 

I am running the latest version (9.0.1) and the database files are accessible, the userrights are on full control and the files are not read only. 

 

Can anyone assist?

Moderator
Posts: 4,395
Country: USA

Re: Act for web 2007 premium, can't restore database to new server

Hello,

In order to avoid board clutter, we ask that you not double or cross-post.


Please look here for replies to your topic.