Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act.Web.API not working as expected

Accepted Solution Solved
Copper Contributor
Posts: 25
Country: United_Kingdom
Accepted Solution

Act.Web.API not working as expected

Hi,

 

I have Act for Web 18.1.103.0, Update 3 installed on Server 2012 R2. This has been working well for a few years. User use a mix of desktop and web access.

 

I now want to setup the Web API for use with the Act Companion mobile app. I am following the steps in this help document https://www.act.com/docs/default-source/user-guides/webapi_admin_guide.pdf

 

Step 5 says

step5.png

 

When I go to my URL, I see

 

default.pngAssuming this wasn't the page the guide intended, I searched around and added /help to the URL, which took me to this

 

help.png

 

However, when I click the TEST button, nothing happens. No errors, no loading, no nothing. I suspect my IIS Application is not working correctly...

 

When I setup this server, Act was deployed to the 'Default Web Site' in IIS. However, due to subsequently adding another website to the same server, I created another IIS website and moved the Applications to this. I therefore have the "Act.Web.API" application showing under my Act IIS site, but haven't made any other changes to the application behaviour/permissions, etc. IIS looks like this...

 

IIS.png

 

 

Perhaps it's best to just uninstall and reinstall Web.API - can I do this without touching the other components of Act, such as the main desktop application or APFW application in IIS? As these are all working fine.

 

Thanks in advance

 

 


Accepted Solutions
Solution
Accepted by topic author mikeyorke
‎11-08-2017 11:48 PM
Administrator
Posts: 387
Country: United_Kingdom

Re: Act.Web.API not working as expected

Hi Mike,

 

I'm really sorry I completely missed that - the Act! Companion app is only supported to work with v19 and higher.

 

 

View solution in original post


All Replies
Employee
Posts: 116
Country: USA

Re: Act.Web.API not working as expected

38385 How do I uninstall the Act! Premium Web API?

http://kb.act.com/app/answers/detail/a_id/38385/kw/web%20api

Copper Contributor
Posts: 25
Country: United_Kingdom

Re: Act.Web.API not working as expected

Thanks! 

 

I followed the steps...uninstalled via Control Panel and manually removed the directory. I checked IIS, the application had not been removed from my custom website, so I manually removed that (right-click, remove). Then installed the latest version from https://developer.act.com/

 

I noticed the Act.Web.API application was added automatically to the 'default web site', which is not where I want it. So, I manually added it to my other website (right-click, add application) browsed to C:\program files (x86)\act\act.web.api and gave it the same name as it shows in the default web site.

 

Now, when I browse to https://mysite.com/act.web.api I get a slightly different page (makes sense as it is a newer version)

actwebapi.png

But, as the help document suggests, there is nowhere to enter a username, password and database to test it is working. 

 

With the previous version of web.api I appended /help to the URL which took me to another page, but this time the URL is not working. I get 404.

 

How can I test this? 

Have I added the application to my custom web site properly? Does web.api need any special configuration in IIS such as permissions?

 

Thanks.

 

 

 

 

Administrator
Posts: 387
Country: United_Kingdom

Re: Act.Web.API not working as expected

I'll look into the documentation that recommends this test, as I think it may be slightly out of date.
An easy way to test that the API is working is to browse to:

<sitename>/act.web.api/api/system

If the API is working fully, it'll return the version of the API and the Act! database like so:

{
"apiVersion": "1.0.202.0",
"sdkVersion": "20.0.159.0"
}

Any other messages like {g2c:unavailable} or HTTP errors indicate that it is not working correctly.

To answer your questions, in my experience the API requires no special permissions - though I'd recommend ensuring that the application 'Basic Settings' in IIS are set to 'Connect-As' > 'Specific User' and then use the impersonation account you should have set up for APFW (local admin).

Hope this helps.


Copper Contributor
Posts: 25
Country: United_Kingdom

Re: Act.Web.API not working as expected

Hi Jon,

 

Many thanks. When I visit that URL, I get

 

{
  "apiVersion": "1.0.223.0",
  "sdkVersion": "18.1.103.0"
}

 

Also, I checked the 'Basic Settings' for Act.Web.API. The 'connect as' settings are set to "application user (pass-through authentication)", which is the same as my APFW settings. See both screen shots below

 

ASGRD_2017-11-02_10-17-19.png

 

ASGRD_2017-11-02_10-17-40.png

 

 

 

As mentioned in my OP, the reason for wanting to set this up is to use Act Companion mobile app. When trying to authenticate, I am getting error 'Verify Server URL is correct'. I am using

 

User Name: <known act username>

Password:  <confirmed working password>

Server Address URL: https://act.companydomain.com (the same url as APFW)

Server Database Name: <exact DB name> (as shown in the drop-down list on the APFW login page)

 

Perhaps if Web.Api is working correctly, there is something else wrong?? I am trying from wifi and 4G, so I know it's not a network issue. DNS is fine as APFW works. Firewall should not be an issue as I'm already successfully using HTTPS for APFW.

 

Confused.

 

Does the companion app work with 18.1?

Solution
Accepted by topic author mikeyorke
‎11-08-2017 11:48 PM
Administrator
Posts: 387
Country: United_Kingdom

Re: Act.Web.API not working as expected

Hi Mike,

 

I'm really sorry I completely missed that - the Act! Companion app is only supported to work with v19 and higher.

 

 

Copper Contributor
Posts: 25
Country: United_Kingdom

Re: Act.Web.API not working as expected

Ah. I see.

 

It would be helpful if this page mentioned that https://www.act.com/products/connections/act!-companion. Under 'Requirements' it simply refers to  the mobile side (iOS/Android) and not about the DB or application it will connect to.

 

Also, under the 'configuration and setup' section further down, it links to a document about Web.API, which mentions v18 is required. And links to KB38287, which mentions v18.2 is required for Web.API

 

Cheers