Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act! Scheduler error. .....filed with the following error: 80040154.

Accepted Solution Solved
New Member
Posts: 4
Country: USA
Accepted Solution

Act! Scheduler error. .....filed with the following error: 80040154.

I get this error on my server.  Outlook and Word are NOT installed on the server, which is the subject of other postings for this error.  This is preventing me from backing up my database.  Running SBS2003 with latest SP.

 

I could not find the CLSID with regedit in the registry.

 

The full message: ACT! Scheduler error.  Retrieving the COM class factory for component with CLSID {number} failed due to the following error: 80040154.  Contact your administrator for assistance.

 

Any ideas how to resolve this?

 

Thanks,

 

Steve

Boston


Accepted Solutions
Solution
Accepted by topic author sgarson
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Act! Scheduler error. .....filed with the following error: 80040154.

10.01 and 10.0.0 can share a database on a LAN, but not with sync... which it sounds like you're using.

 

I don't know that CLSID and can't find a reference to it. I can only really suggest a reinstall to fix it

 

This is a procedure I wrote to get the most clean install possible:
Uninstall any version of ACT! from Windows Control Panel | Add/Remove Programs
Use the Uninstaller.exe from the ACT! KB 19338 (the exe, not the manual uninstall)
Uninstall .Net Framework (all versions) - this does NOT apply to Vista users as .Net 2.0 is part of the OS and can't be uninstalled
Perform a Selective restart with MSCONFIG as per ACT! KB 14499
Install ACT! 10.0 full install
Restore from Selective Startup Mode with MSCONFIG
Reboot

View solution in original post


All Replies
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Act! Scheduler error. .....filed with the following error: 80040154.

What is the CLSID number? 

What version of ACT! (the full build from Help | About)?

Is the database on the same machine?

New Member
Posts: 4
Country: USA

Re: Act! Scheduler error. .....filed with the following error: 80040154.

The database is on the same server.  I am scheduling from ACT on the server.

 

CLSID{C72F554F-578C-BF99-006008C0F63B}

 

Act Premium 2008 ST Edition Ver 10.0.0.237, Hotfix 1.

 

I have not upgraded to the latest hotfix since the db will not be compatible with Hotfix 1 and I have some challenges with getting field amachines upgraded.

 

Thanks.

 

 

Solution
Accepted by topic author sgarson
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Act! Scheduler error. .....filed with the following error: 80040154.

10.01 and 10.0.0 can share a database on a LAN, but not with sync... which it sounds like you're using.

 

I don't know that CLSID and can't find a reference to it. I can only really suggest a reinstall to fix it

 

This is a procedure I wrote to get the most clean install possible:
Uninstall any version of ACT! from Windows Control Panel | Add/Remove Programs
Use the Uninstaller.exe from the ACT! KB 19338 (the exe, not the manual uninstall)
Uninstall .Net Framework (all versions) - this does NOT apply to Vista users as .Net 2.0 is part of the OS and can't be uninstalled
Perform a Selective restart with MSCONFIG as per ACT! KB 14499
Install ACT! 10.0 full install
Restore from Selective Startup Mode with MSCONFIG
Reboot

Moderator
Posts: 4,395
Country: USA

Re: Act! Scheduler error. .....filed with the following error: 80040154.

[ Edited ]

Just realized, I linked the wrong KB

 

Its worth a shot to register the following DLL.  No guarantee it will work, but it could save a lot of time with a reinstall.

 

  1. Go to Start > Run and type in cmd
  2. Type the following command: cd C:\Program Files\ACT\ACT for Windows
  3. Then type regsvr32 adchronopher.dll
Message Edited by DLunceford on 06-18-2008 05:06 PM
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Act! Scheduler error. .....filed with the following error: 80040154.

Could the CLSID actually be C72F554F-578C-11D5-BF99-006008C0F63B

 

That's part of the Scheduler - not sure which DLL to manually re-register. So a reinstall looks best bet

New Member
Posts: 4
Country: USA

Re: Act! Scheduler error. .....filed with the following error: 80040154.

That link appears to require a paid support account.
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Act! Scheduler error. .....filed with the following error: 80040154.


DLunceford wrote:

Hello,

 

Try the following KB before uninstalling the product.


Please see the following on-line Knowledge Base (KB) document that covers this issue.
Error: "Error Retrieving the Com Class Factory for Component CLSID {C72F5552-578C-11D5-BF99-006008CO...

Message Edited by DLunceford on 06-18-2008 04:56 PM

 

Which is the CLSID I thought it might be... but the KB link returns:

 

Log On Required!
You are attempting to access an area that requires logging on.
Please log on via one of the links provided on the left-hand side.
Thank you.

New Member
Posts: 4
Country: USA

Re: Act! Scheduler error. .....filed with the following error: 80040154.

Yes, that is the number.
Moderator
Posts: 4,395
Country: USA

Re: Act! Scheduler error. .....filed with the following error: 80040154.

Yes, I linked a bad KB.  I wrote the steps in my previous post.