Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act! Connect link unable to establish connection with Zapier

Copper Elite Contributor
Posts: 145
Country: Australia

Act! Connect link unable to establish connection with Zapier

I am looking for any additional information that is available on how the Act! connect link works, and what exactly needs to be open or available for it to work correctly.

 

The scenario I have is setting this up for a client of ours.

We wanted to install Act! Connect link so that we could use it to import signups from WPForms into Act! as Contacts through Zapier.

 

I installed the connector, it showed its process as running and gave me a url in the act! GUI for me to use.

 

When I tried setting up the Zap connection, I was getting an error that it could not connect.

 

I tried visiting the URL directly and for some reason it was being re-directed to our clients home page.

 

I tried updating the connector to use port 8080 instead of port 80 and then i got this message when visiting the url:

 

{"g2c":"unavailable"}

 

 

I have tried removing and reinstalling the plugin but this has not made any change.

the only constant is that when it is setup in its default configuration it redirects to the clients home page.

 

I am fairly certain there is something about their server configuration that is causing the issue but I do not know what.

 

I did try looking for more information on what ports need to be enabled and what exceptions need to be open in the firewall but this information appears to be very sparse.

 

Is anyone able to advise what needs to be open/enabled for the link to be able to connect sucessfully?

 

Jared Dalrymple | Technical Consultant | P:+61 7 3423 3551
jared@evolutionmarketing.com.au | Evolution Marketing Services


Administrator
Posts: 1,371
Country: United_Kingdom

Re: Act! Connect link unable to establish connection with Zapier

[ Edited ]

The Act! Connect Link acts as a virtual tunnel to port 80 on your machine - if you have a website that redirects all traffic on port 80 then it will be directed to that site instead of the API.

Unfortunately the Connect Link cannot be configured for a different port. You could look at your websites web.config file and make changes - but if you don't want to do this, or aren't sure what you'd need to change there is another option.

I'd recommend installing Act! Premium for Web - it's essentially the same as Act! Premium except it has a bunch of extra web features. One of these features is the full configurable Web API which can be configured to run on any port. It's a little more complicated to set up, but it is included as part of your Act! Premium subscription/purchase.

Essentially, you'll need to install Act! Premium for Web (APFW) on the server only - and install the Act! Web API, then open your database as normal and go to Tools > Website Administration. Once you've run through the website set up (more info here: KB 14843 - How to Use the Web Site Administration Tool) - you can then go into IIS and configure the Act! Web API application, and (if you want to) disable the Act! database website.

Like I've said, it's a little complicated to set up so if you need any assistance, I'd recommend getting in touch with our support network - https://www.act.com/au/contact-us

Nickel Elite Contributor
Posts: 473
Country: USA

Re: Act! Connect link unable to establish connection with Zapier

[ Edited ]
 

I  suggest the direct assitance of a ACC Act! Certified Consultant in your area, it saves a lot of time and with good resultsa

 

 

Evolution Marketing

Location: Underwood

Contact: Ben Hamilton

Email: ben@evolutionmarketing.com.au

Website:www.evolutionmarketing.com.au/software/act

Telephone: (+61) 07 3423 3551

 

 

Act Today Pty Ltd

Location: Brisbane

Contact: James Eldridge

Email: james@acttoday.com.au

Website: www.acttoday.com.au

Telephone: +61 07 3041 4195

PRAXI SOLUTIONS INC (CRM and FSM Solutions)
contactus@praxisol.com
customercare@praxisol.com
https://www.praxisol.com/solutions