Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act! Connect Link URL Disappeared from Act! for Windows

Accepted Solution Solved
New Member
Posts: 2
Country: USA
Accepted Solution

Act! Connect Link URL Disappeared from Act! for Windows

So last week I successfully made a Zapier connection to Act via Act Connect Link on my Act for Windows Database. Today when it stopped working, I went into Act to find the URL from the top of the Act Connect tab had disappeared. I've since attempted to uninstall, reinstall, etc, with no luck.

 

Any thoughts?


Accepted Solutions
Solution
Accepted by JonTaylor (Administrator)
‎10-20-2017 03:24 AM
Administrator
Posts: 390
Country: United_Kingdom

Re: Act! Connect Link URL Disappeared from Act! for Windows

Hmm, ok, so if you navigate to the install directory of Act! (default location for this is C:\Program Files (x86)\ACT) do you see an Act.Web.API directory?

 

If you do, you can create the application in IIS.

 

1) Right click on the APFW2 site then choose Add Application...

2) Under Alias type "act.web.api"

3) In Physical Path, click the three dot icon and then browse to C:\Program Files (x86)\ACT\Act.Web.API

4) Click Connect As, and either use Pass through Authentication - or enter the specific credentials of a local administrator user.

5) Test Settings, make sure you don't get any Red 'X' icons.

6) Click OK.

 

If you don't have this directory then the API is not installed at all. In this case, I'd recommend reinstalling Act.

 

You can test the API by browsing to localhost/act.web.api/api/system making sure that the HTTP bindings of the APFW2 Site are set to http Port 80 (Highlight the APFW2 site, and choose Bindings... on the right).

 

 

View solution in original post


All Replies
Employee
Posts: 116
Country: USA

Re: Act! Connect Link URL Disappeared from Act! for Windows




38400 Act! Connect Link URL is missing from the Act! Connect View

http://kb.act.com/app/answers/detail/a_id/38400/kw/Act!%20Connect%20Link

 

 

38399 No endpoint available in the Act! Connect Link application

http://kb.act.com/app/answers/detail/a_id/38399

 

 

38336 How do I install the Act! Connect Link?

http://kb.act.com/app/answers/detail/a_id/38336/kw/Act!%20Connect%20Link

New Member
Posts: 2
Country: USA

Re: Act! Connect Link URL Disappeared from Act! for Windows

I've attempted all of these steps multiple times but find myself at "Unable to register" within the console of Act Connect Link.

 

 

Employee
Posts: 116
Country: USA

Re: Act! Connect Link URL Disappeared from Act! for Windows

Ensure that inbound and outbound exceptions for Port 22 have been added to your antivirus or firewall. For information on adding these exceptions, refer to your antivirus or firewall documentation, or refer to an IT Professional.

Second, in order to use the Act! Connect Link with Act! Premium, you must have a valid subscription. 

 

If you intend to use the Act! Connect Link with a database or databases which are shared across your network, the Act! Connect Link must be installed on the server where the database files reside

New Member
Posts: 8
Country: USA

Re: Act! Connect Link URL Disappeared from Act! for Windows

Apologies in advance for the many questions Smiley Wink

I am getting the ACT! Connect link in ACT! Premium for Web that we host on our own server, however we are not able to use it to login with ACT! Companion Mobile App.

We have added inbound and outbound exceptions for Port 22 on Windows 10 antivirus / firewall (is this necessary even if both the firewall and antivirus are disabled BTW?)

Is it also necessary to add port 22 under bindings in IIS settings under APFW site? And if so does it have to be https or can it just be http?

We cannot get the ACT! Connect link shown to resolve / connect no matter what we try.

Thanks in advance for any suggestions.
Administrator
Posts: 390
Country: United_Kingdom

Re: Act! Connect Link URL Disappeared from Act! for Windows

Hi MMicha07,

 

You've mentioned that you're using the Connect link with Act! Premium for Web on your own hosted server, can I just clarify that you've installed the 'Act! Connect Link' and 'Act! Web API Hosted'. These should be visible in Programs and Features,  and would be installed together.

 

By default, if you install Act! Premium for Web, you'll be prompted to install the Act! Web API (not the hosted version) - which does not install the Connect Link.

 

Essentially, the Connect Link is just a 'tunnel' to your machine which bypasses the need for a Static IP/Port Forwarding. It's assumed that if you're hosting your own Act! Premium for Web site, you'll already have these set up so the Connect Link isn't included.

 

If you definitely do have the Connect Link + Act! Web API Hosted installed, check the Services window (Windows Key + R, then type services.msc) and ensure that both the 'ActConnectLink' and 'Act! Web API Host' services are running.

New Member
Posts: 8
Country: USA

Re: Act! Connect Link URL Disappeared from Act! for Windows

ACT! Connect Link is installed in Programs and running in services, ACT! Web API Hosted does not show installed in Programs and is not shown in services FYI.

 

When I was having issues using ACT! Companion after installing ACT! 20, support helped me manually install ACT! Connect Link 1.1.13 which at least got part of it going, and got me the ACT! Connect URL to show after choosing ACT! Connect in the desktop program.

 

Just to clarify I am running ACT! Premium for Web version 20 with latest updates, hosting on our own server.

 

The ACT! support rep told me everything looked installed properly now and thought maybe the fact that port 22 was showing as not open at canyouseeme.org was the problem. I could only get port 22 to show as open if I went into IIS and added it under Bindings under the APFW site, however I'm not sure I configured it properly (http or https, etc...), and even after adding the port 22 there, I cannot still login on ACT! Companion mobile app using the URL in the desktop version of ACT!.

 

Maybe the ACT! Web API Hosted not being installed / running in services is part of the issue?

 

I am a little frustrated that no one at ACT! support I have talked to so far seems to be well enough versed with the proper setup parameters, and editing of IIS settings...any help or advise would be greatly appreciated.

 

Thanks!,

Administrator
Posts: 390
Country: United_Kingdom

Re: Act! Connect Link URL Disappeared from Act! for Windows

[ Edited ]

While Port 22 may be required to allow traffic, it may not display as a listening or open port, as it isn't used as an endpoint for the service.

As mentioned before the Connect Link acts as a tunnel which 'kicks out' on port 80 on your local machine.

 

 

 

There've been quite a few changes to the way the API is installed and presented in v20. So I've done a little research, and I understand that now, in v20, the API comes installed as a part of Act! and no longer appears in Programs and Features as a separate program.

 

The "Act Web API" (not hosted) that comes with Act! Premium for Web doesn't run as a service any more either, it now runs exclusively as an application in IIS.

 

However, the "Act Web API Hosted" packaged with Act! Premium for Windows does run as a service, but won't show in Programs and Features.

 

So to recap, it sounds like the set-up that you have there is:

 

1) The Act Web API is running as an IIS application

2) The Connect Link service is installed and running

 

While this isn't the usual set up (usually the Connect link is used with the Web API Hosted) it should work.

 

Could I ask you to test something, please open a browser directly on the server machine and browse to localhost/act.web.api/api/system 

 

If this returns something like:

 

{
  "apiVersion": "1.0.202.0",
  "sdkVersion": "20.0.159.0"
}

 

Then we'll know that the API itself is working, and the issue lies with either the tunnel or external access.

 

If it returns "g2c unavailable" or a 404 error, then we know the issue lies with the API itself.

 

New Member
Posts: 8
Country: USA

Re: Act! Connect Link URL Disappeared from Act! for Windows

Thanks for the response Jon,

 

the "Act Web API Hosted" is definitely not showing up running in services (and not showing installed in Programs as you mentioned).

 

Browser test returns the following:

 

HTTP Error 404.0 - Not Found The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.
Most likely causes:
  • The directory or file specified does not exist on the Web server.
  • The URL contains a typographical error.
  • A custom filter or module, such as URLScan, restricts access to the file.
Things you can try:
  • Create the content on the Web server.
  • Review the browser URL.
  • Create a tracing rule to track failed requests for this HTTP status code and see which module is calling SetStatus. For more information about creating a tracing rule for failed requests, click here.
Detailed Error Information:
Module Notification Handler Error Code
   IIS Web Core
   MapRequestHandler
   StaticFile
   0x80070002
Requested URL Physical Path Logon Method Logon User
   http://localhost:80/act.web.api/api/system
   C:\inetpub\wwwroot\act.web.api\api\system
   Anonymous
   Anonymous
 
More Information:This error means that the file or directory does not exist on the server. Create the file or directory and try the request again.

View more information »

Administrator
Posts: 390
Country: United_Kingdom

Re: Act! Connect Link URL Disappeared from Act! for Windows

Ok, so it's not specifically an issue with the Connect Link - looks like the API isn't operating correctly.

 

If you open the IIS Manager, and look at your Default Site - it should hopefully look like this:

 

IIS-ActWebApi.png

 

Note the act.web.api application under the Default Web Site.

 

Make sure that this exists and that if you click Basic Settings on the right, you can Test Settings... and not get any Red 'X' symbols (you may get a Yellow warning triangle, this does not necessarily mean anything is incorrect).

 

If the application is there, and the test settings works, I'd recommend checking your site http bindings (Click on the Site and then Choose Bindings... from the right hand menu) - by default these should be set to use http port 80 and would only have changed if you've decided to change them.

 

If they're set to any other port, you'll not be able to use the Connect Link to route through as it will always tunnel to port 80.

 

You can however access the API locally on

localhost:<port number>/act.web.api/ 

 

or via the machines IP address/domain address

<machineaddress>:<port>/act.web.api/

 

The act.web.api/api/system path should just make a quick call to the API to return the version number, so it's a handy way to test if the API is working.

A successful result will return the version of the API and of Act!