Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act! Companion connection issues - cannot connect to self hosted instance of act!

Copper Contributor
Posts: 38
Country: Hong_Kong

Re: Act! Companion connection issues - cannot connect to self hosted instance of act!

> In the interim the issue can be resolved by updating the webconfig file for Act!/API to include both http://localhost:9595 AND https://localhost:9595.

 

Could you be a bit more explicit as to which entries I need to add/modify in the (I assume) /APFW/web.config file?

Nickel Super Contributor
Posts: 443
Country: Germany

Re: Act! Companion connection issues - cannot connect to self hosted instance of act!

Sorry the links leads to a "restricted area" of the community.

 

Here's the text containing the solution:

 

-------begin quote-------------------------

 

Start the notepad editor as administrator.

 

In the editor open the web.config file from the installtion folder of the ACT.Web.Api.

 

Example folder: C:\Program Files (x86)\ACT\Act.Web.API

 

Go to Line:

<add key="EnabledCorsOrigins" value="file://127.0.0.1,https://actcompanion.actops.com,https://office365connector.actops.com" />

 

Replace it with this line:

 

<add key="EnabledCorsOrigins" value="file://127.0.0.1,https://actcompanion.actops.com,https://office365connector.actops.com,http://localhost:9595,https://localhost:9595" />

 

Save the web.config file.

 

If you use Act! Premium for Web restart the IIS server. Open Administrator command prompt (cmd.exe) and execute the command:

 

iisreset

 

If you use Act! Premium restart the ACT.Web.API service. Open Administrator command prompt (cmd.exe) and execute the commands:

 

net stop ActWebApiService

net start ActWebApiService

 

-------end quote-------------------------

 

Andreas Schlesselmann
Melville-Schellmann GbR
Germany
www.melville-schellmann.de
Copper Contributor
Posts: 38
Country: Hong_Kong

Re: Act! Companion connection issues - cannot connect to self hosted instance of act!

No joy.

 

I edited web.conf in C:\Program Files (x86)\ACT\Act.Web.API (which is the correct location for my premium web api installation, and I changed the  the line with EnabledCorsOrigins to the following:
<add key="EnabledCorsOrigins" value="file://127.0.0.1,https://actcompanion.actops.com,https://office365connector.actops.com,http://localhost:9595,https://localhost:9595" />

 

I did an iisreset as administrator - and I still cannot log in.

 

I did a stop/start of the World Wide Web publishing service, and I still cannot log in.

 

In my iis log file, I see the following:

2019-02-08 09:58:58 10.10.1.66 GET /act.web.api/api/system - 443 - 10.10.1.201 Mozilla/5.0+(iPhone;+CPU+iPhone+OS+12_1+like+Mac+OS+X)+AppleWebKit/605.1.15+(KHTML,+like+Gecko)+Mobile/16B92/pcqydqmuvtxcyxqmrriafpazrzumgkoo http://localhost:9595/login 200 0 0 15
2019-02-08 09:58:58 10.10.1.66 OPTIONS /act.web.api/authorize - 443 - 10.10.1.201 Mozilla/5.0+(iPhone;+CPU+iPhone+OS+12_1+like+Mac+OS+X)+AppleWebKit/605.1.15+(KHTML,+like+Gecko)+Mobile/16B92/pcqydqmuvtxcyxqmrriafpazrzumgkoo http://localhost:9595/login 404 0 2 15

 

So, I'm still not having any luck.

 

Any other suggestions would be appreciated.

Highlighted
Copper Super Contributor
Posts: 46
Country: Germany

Re: Act! Companion connection issues - cannot connect to self hosted instance of act!

[ Edited ]

Moin Paul,

 

you wrote in your first post: "However, when I try to use the Act! Companion mobile app, it will not let me connect.  I get a "User Login failed" message."

This is not the message that comes in the new build of the Act! Companion App (I can only speak for the Android App) that needs the insertion of ",http://localhost:9595,https://localhost:9595" in the web.config file mentioned by Andreas and Jeff.

You'll need this modification, if you get the message "Verify database URL".

So I think you have a different problem.

May be you really have a problem with the login data.

Try to create a simple username like "testuser" and password "abcd1234" (only Ascii chars) - only for a test.

Can you verify which version of the Act! Companion app you are using?
What version of the Act.Web.Api is installed? Try: https://act.[mydomain].com/act.web.api/api/system

 

Best regards
Robert

 

 

Melville-Schellmann
Consulting and Development for CRM-Software
Copper Contributor
Posts: 38
Country: Hong_Kong

Re: Act! Companion connection issues - cannot connect to self hosted instance of act!

> you wrote in your first post: "However, when I try to use the Act! Companion mobile app, it will not let me connect.  I get a "User Login failed" message."

This is not the message that comes in the new build of the Act! Companion App (I can only speak for the Android App) that needs the insertion of ",http://localhost:9595,https://localhost:9595" in the web.config file mentioned by Andreas and Jeff.

 

This is the error I get:

IMG_5334.PNG

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

> You'll need this modification, if you get the message "Verify database URL".

So I think you have a different problem.

May be you really have a problem with the login data.

Try to create a simple username like "testuser" and password "abcd1234" (only Ascii chars) - only for a test.

 

I'm using a 2 character username and password using standard ascii characters.  This login works for the desktop client, the web api at https://act.[mydomain].com/act.web.api/swagger/index.html, and the web version of act at https://act.[mydomain].com/apfw/

 

> Can you verify which version of the Act! Companion app you are using?

 

ios Act! Companion v2.3.1 from the US app store

 

> What version of the Act.Web.Api is installed? Try: https://act.[mydomain].com/act.web.api/api/system

 

{
"apiVersion": "1.0.317.0",
"sdkVersion": "21.0.295.0"
}

Copper Super Contributor
Posts: 46
Country: Germany

Re: Act! Companion connection issues - cannot connect to self hosted instance of act!

[ Edited ]

Moin Paul,

 

only for information, My Act! Companion App is the version 2.3.54 from the Google Play Store.

 

In your iPhone screenshot you've entered the .../apfw/ URL for the Act! Premium for Web desktop browser front end.

But you'll have to enter the Act! Web API URL:

 

https://act.[mydomain].com/act.web.api

 

Best regards
Robert

Melville-Schellmann
Consulting and Development for CRM-Software
Copper Contributor
Posts: 38
Country: Hong_Kong

Re: Act! Companion connection issues - cannot connect to self hosted instance of act!

[ Edited ]

No joy.  I get the same User Login failed error 

 

From the IIS log file:

 2019-02-11 11:36:20 10.10.1.66 OPTIONS /act.web.api/authorize - 443 - 10.10.1.201 Mozilla/5.0+(iPhone;+CPU+iPhone+OS+12_1+like+Mac+OS+X)+AppleWebKit/605.1.15+(KHTML,+like+Gecko)+Mobile/16B92/rvuskqiglkewtgzjolduzmhijlrcpzly http://localhost:9595/login 404 0 2 0

 

When I was testing the act client with a demo account from act.com, I used the /apfw/ url and it worked.  It seems that it silently redirects the mobile client to the correct location.  If you'll noticed, I get the same log file entry from the /act.web.api/ as I do from the /apfw/ url.

 

Looking more closely, I see this

2019-02-11 11:36:20 10.10.1.66 GET /act.web.api/api/system - 443 - 10.10.1.201 Mozilla/5.0+(iPhone;+CPU+iPhone+OS+12_1+like+Mac+OS+X)+AppleWebKit/605.1.15+(KHTML,+like+Gecko)+Mobile/16B92/rvuskqiglkewtgzjolduzmhijlrcpzly http://localhost:9595/login 200 0 0 3765
2019-02-11 11:36:20 10.10.1.66 OPTIONS /act.web.api/authorize - 443 - 10.10.1.201 Mozilla/5.0+(iPhone;+CPU+iPhone+OS+12_1+like+Mac+OS+X)+AppleWebKit/605.1.15+(KHTML,+like+Gecko)+Mobile/16B92/rvuskqiglkewtgzjolduzmhijlrcpzly http://localhost:9595/login 404 0 2 0

 

Specifically, 

  • http://localhost:9595/login 200

followed by 

  • http://localhost:9595/login 404

which seems a bit strange in that one moment it finds the page (200, 3765 bytes returned) and then gets a 404 error.