Showing results for 
Search instead for 
Do you mean 

Act 2009 and Crystal--rows not appearing

Tuned Listener
Posts: 10
Country: United States

Act 2009 and Crystal--rows not appearing

[ Edited ]

I got a headscratcher:


I have Act 2009 Premium with CR XI (and tested it on the free trial of CR 2008) with ACT Reader exposing the database through ODBC. I'm pulling data that combines company tables and Top Line Designer tables into a couple of different reports. In fact I have two vesions of the same basic report: one has one group of fields and the other report a different group of fields. The selection criteria and table 'linkage' is the same in both reports.


Here's where it gets strange: In the first report I get 825 records returned in the report. In the second report I get 787 records. Again, same selection criteria and table linkage in CR.


When I played around with the second report to try to figure out the cause of the discrepancy I discovered that if I remove one particular field the report than will return the correct number of records: 825. When I put back the 'troublesome' field the report goes back to reporting 787 records.


I've repaired the database; reindexed the database; tried using a formula to generate the value thinking it may be a null value issue (it's not--because I can test for null and those records that have a null value do appear in the report). The database is current, with 11.1 and the hotfix applied. The report still returns 787 if that 'troublesome' field is included.


I posted to experts-exchange (highly recommend them!) because I first thought it was a Crystal issue. During a short on-line exchange it was pointed out that the 'troublesome' field is the only field in the report that comes from one particular company table--let's call it CO_Table3 (I have 4 custom company tables--we've added a lot of fields). I tried replacing the 'troublesome' field with another field from CO_Table3 and got the same behavior--only 787 records appeared--and not the full set of 825. Again, if I don't include any fields from this one table it works correctly... as soon as I include a field from CO_Table3 it returns the smaller set.


I have no idea why this is doing this. I'm at a loss as to why and how to address this? Any ideas? 


Any help would be appreciated.

Message Edited by mbudzyn on 07-28-2009 11:24 AM