Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act! 2007 not starting, ActSage.exe running at 50% CPU

New Member
Posts: 2
Country: USA

Act! 2007 not starting, ActSage.exe running at 50% CPU

I have a number (30+) installations of Act!2007 running on Windows XP.  For the second time, one of the installations has, for no apparent reason, stopped working.  Act! will not start (no splash or GUI appears) and there is a process called ActSage.exe which will run at 50% CPU forever (until killed).  That last time that this happened (on a different machine) I was unable to resolve the issue even after multiple cycles of uninstall/reinstall and had to reinstall the OS to resolve the issue.
 
Has anyone encounter this and have any success resolving it?
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Act! 2007 not starting, ActSage.exe running at 50% CPU

[ Edited ]
What version of ACT!? I'd make sure you're running 9.01 and Hotfix3
 
Is there any error in the Event Log?
 
When you uninstall ACT!, also uninstall and reinstall .Net before reinstalling ACT!


Message Edited by GLComputing on 02-03-2008 05:23 AM
New Member
Posts: 1
Country: USA

Re: Act! 2007 not starting, ActSage.exe running at 50% CPU

Did you ever hear back? I have tried the complete uninstall of ACT!, .NET Frameworks (all of them), SQL and then a reinstall and have still had no success. Is the only fix restaging the computer?
Copper Contributor
Posts: 97
Country: USA

Re: Act! 2007 not starting, ActSage.exe running at 50% CPU

Hello,
 
Yes, there should be a way to fix this without restaging the entire machine.
 
Did you check the event log for any errors from ACT!?
 
How about ACT!'s log located at: C:\Documents and Settings\username\Application Data\ACT\ACT for Windows 10\ACTLOG.xml
 
You can increase ACT's logging verbosity by modifying the values under C:\Program Files\ACT\Act for Windows\ActSage.exe.config:
  <switches>
   <add name="ACTCoreSwitch" value="5" />
   <add name="ACTUISwitch" value="5" />
   <add name="ACTSecuritySwitch" value="5" />
   <add name="ACTSyncSwitch" value="5" />
   <add name="ACTSyncSetupSwitch" value="5" />
   <add name="ACTDesignTimeSwitch" value="5" />
   <add name="ACTExtendedSwitch" value="5" />
   <add name="ACTReportingSwitch" value="5" />
  </switches>
After modifying ActSage.exe.config, launch ACT! again (make sure ActSage.exe is NOT running first), wait for a bit, then see if you have anything interesting in ACTLOG.xml.
 
HTH,
jason
Jason Sellers
ACT! Engineer 2000-2007
New Member
Posts: 2
Country: USA

Re: Act! 2007 not starting, ActSage.exe running at 50% CPU

I tried setting logging to verbose and it turns out that the ACTLOG.XML has not been modified since the problem started.  Stopping/restarting ACT! doesn't update it as well as bouncing the entire machine.  It looks like it spinning out of control prior to the point that Act! starts logging to this file.
 
 
Copper Contributor
Posts: 97
Country: USA

Re: Act! 2007 not starting, ActSage.exe running at 50% CPU

And nothing in the system event log?
 
It's quite technical, but you could try running the .Net Framework assembly binding log viewer.  You'll need Visual Studio or at least the .Net Framework SDK.  More info can be found at: http://msdn2.microsoft.com/en-us/library/e74a18c4(VS.80).aspx  This tool will tell you if, upon launch, ACT! cannot find a required resource assembly.
 
Also, after you uninstalled ACT!, did you look at your GAC (Global Assembly Cache)?  If you have a server OS or the .Net Framework SDK installed you can find a utility for this under Administrative Tools | Microsoft .Net Framework 2.0 Configuration.  It could be that you need to manually remove some ACT! assemblies from your GAC before reinstalling.  This is all assuming that you're using a recent version of ACT!  If v6 or prior, the GAC and .Net do not apply, and I can't remember offhand when ACT! switched from .Net 1.1 to .Net 2.0.
 
Sorry so technical... but I know no other way!  Smiley Wink
 
jason
 
Jason Sellers
ACT! Engineer 2000-2007
Copper Super Contributor
Posts: 54
Country: Canada

Re: Act! 2007 not starting, ActSage.exe running at 50% CPU

I have come across this problem multiple times.
 
It seems it's to do with some system files related to the registration of Act thrown into some sort of loop.
 
This was the solve I found:
 
1. go to c:\windows\system32
2. enable show hidden files AS WELL as system files
3. sort by extension
4. there should be a couple system files ( .SYS ) that are 8 randomly generated numbers and letters all in upper case (back these up first) then delete them. (they should be the only .sys  files in upper case)
5. reboot and restart Act ( you will have to enter in your registration information again )
 
These files are associated with the registration of certain programs. Deleting them may mean you have to register any other programs associated with these files, otherwise there should not be any danger.
 
 
Hope that helps fix your issue!
 
 
Michael Kadlec
Act! Certified Consultant
 
Michael Kadlec
Act! Certified Consultant
Corelogix Corporation
New Member
Posts: 1
Country: Netherlands

Re: Act! 2007 not starting, ActSage.exe running at 50% CPU

Thanks! That solved the issue for me.
New Member
Posts: 1
Country: United Kingdom

Re: Act! 2007 not starting, ActSage.exe running at 50% CPU

Worked for me too! Only one file had to be deleted. Thanks from a grateful user whose Outlook had been taken down also by this problem.
Copper Super Contributor
Posts: 63
Country: USA

Re: Act! 2007 not starting, ActSage.exe running at 50% CPU

saved my life!

Danielle Major
Ki Consultants