Community
Showing results for 
Search instead for 
Do you mean 
Reply

APFW - Send Activity E-Mail to Contact Greyed Out

Accepted Solution Solved
Copper Contributor
Posts: 79
Country: Australia
Accepted Solution

APFW - Send Activity E-Mail to Contact Greyed Out

Using Act! Premium (Web) Version 18.1.103.0, Update 3 on Windows Server 2008 STD.

 

On a windows 10 laptop downloaded the email integration and setup the email details and test email attach to the history but the "Send Activity E-Mail to Contact" on the activity scheduler is greyed out.2017-03-15_10h43_22.png

 

 

 

I have tried in Chrome and IE both the same.  Also noticed that "Act! e-mail composing options is greyed out too.  One other thing we noticed is the option "When clicking an e-mail address, open a new message window in my default e-mail application" does not have a tick, but in APFW if I click on an email address it does open a new message window.  Not really sure if this is an issue from the workstation of the server.

2017-03-15_10h43_06.png

Thanks

Damon

 

 

 


Accepted Solutions
Solution
Accepted by topic author Damon_T
‎06-04-2017 08:02 PM
Administrator
Posts: 4,024
Country: United_Kingdom

Re: APFW - Send Activity E-Mail to Contact Greyed Out

Hi Damon,

 

You're right that the "Send Activity E-Mail to Contact" option only works in IE, and is not supported in other browsers.

 

The issue with the toolbar you have pictured in the screenshot looks like the affected PC has compatibility view enabled in IE for the website.
If I enable this feature, my interface ends up looking the same way as the screenshot, but displays correctly when I remove it from compatibility view.
The recommendation and details steps for this are in the Knowledgebase article which @Horn posted above.

View solution in original post


All Replies
Administrator
Posts: 4,024
Country: United_Kingdom

Re: APFW - Send Activity E-Mail to Contact Greyed Out

Hi Damon,

So the Act! Premium for (Web) Outlook Addin is installed correctly in Outlook, and history recording is working?

Have you tried restarting the IIS services on the server with the IISRESET command as administrator?
Clear the browser cookies and cache, then log back into the database. is the checkbox on the Schedule Activity window now available?

The bottom section in the email preferences window under the heading "Act! e-mail composing options" are only available and used when the Act! Premium e-mail system is being used. It is expected to be unavailable when Outlook integration is set up instead.
Copper Contributor
Posts: 79
Country: Australia

Re: APFW - Send Activity E-Mail to Contact Greyed Out

Thanks for the reply Gary

 

Yes the plugin was downloaded from the preferences and configured the address book.  Can click on the email hyperlink and a new email windows will appear.  Emails are attaching to the history.

 

I had not tried from the command line.  I have now tested this but still the same issue.  I removed the plugin and reinstalled, used the command line reset as an admin and cleared the cache also tried another machine.  Tried IE and chrome same issue.

 

Ok interesting.  We really only want to be able to send invitations from outlook using APFW and don't want to attach emails.  We will be using a 3rd party tool to do this.

 

Cheers

Damon

Administrator
Posts: 4,024
Country: United_Kingdom

Re: APFW - Send Activity E-Mail to Contact Greyed Out

Hi Damon,

I forgot one other thing worth mentioning. The "Send Activity E-Mail to Contact" option is only available for non-user contacts in the database. Can you check that it's not just a user you're trying to use this feature with?
Copper Contributor
Posts: 79
Country: Australia

Re: APFW - Send Activity E-Mail to Contact Greyed Out

Hi Gary

 

Yes we are testing with a contact not a user.

 

Thanks

Damon

Copper Contributor
Posts: 79
Country: Australia

Re: APFW - Send Activity E-Mail to Contact Greyed Out

Hi Gary

 

We are still having this issue.  We did a full reboot on the server and confirmed we are scheduling with a contact and not a user.

 

What else could I check?

 

Thanks

Damon


Gary W wrote:
Hi Damon,

I forgot one other thing worth mentioning. The "Send Activity E-Mail to Contact" option is only available for non-user contacts in the database. Can you check that it's not just a user you're trying to use this feature with?

 

Moderator
Posts: 451
Country: United_Kingdom

Re: APFW - Send Activity E-Mail to Contact Greyed Out

Hi Damon,

 

I have tested this by removing my APFW integration and once removed the box will grey out, once reinstalling again by just refreshing the page the option became available.

In case this is an issue with the integration install I would recommend uninstalling: Act! Premium (Web) installation and redownloading from the APFW website.

Copper Contributor
Posts: 79
Country: Australia

Re: APFW - Send Activity E-Mail to Contact Greyed Out

Thanks for the reply, just so I am clear.  I am best to uninstall APFW from the server and reinstall fresh?  Would I also be best to maybe turn off / uninstall IIS too?

 

Cheers

Damon

Moderator
Posts: 451
Country: United_Kingdom

Re: APFW - Send Activity E-Mail to Contact Greyed Out

This would not need to be carried out the server. it would need to be uninstalled from the individual PC's experiencing the issue.

Please see the articles below for steps i preformed.

 

20353 How to Uninstall ACT! Premium for Web Outlook Integration

38231 What are the recommended browser settings for using Act! Premium (access via web) v18 and late...

 

I hope this resolves the issue!

Copper Contributor
Posts: 79
Country: Australia

Re: APFW - Send Activity E-Mail to Contact Greyed Out

Thanks Dan

 

In Internet Explorer with the changed settings does work when I create email invites (But does not work on Chrome at all.  I assume this is not supported?).  

 

But the blue bar in Act! is the incorrect size and the new button is missing it's icon.  I suspect this is an IE setting because from my machine it looks right.  I have tied on 2 of the customers workstations and they both look funky.

 

We all have the same version of IE 11.1198.14393.0  I am using windows 10.  Customer is using a windows 10 and 8.

I configured both of the customers workstations the same as mine but still looks off.  Here is a screenshot.

2017-06-01_11h42_25.png

 

 This is my bar that looks fine.  From my machine.  Logging into the same instance.2017-06-01_11h51_58.png

 

Do you know what setting control the bar look and buttons?

 

Thanks

Damon