Showing results for 
Search instead for 
Do you mean 

ACT v22.1 Address book is blank

New Member
Posts: 1
Country: USA

ACT v22.1 Address book is blank

Hello everyone,

Currently we are using ACT! Premium V21 and it works fine.

We plan to upgrade to ACT! V22.1 but we face an issue.


When we upgrade the database file to ACT! v22, the Outlook address book is blank, but the name of all the groups are displayed, just the contact part is empty.


From what I read, from ACT v22, they pull contacts from API or something instead of the old way.

The problem is everything works fine with the DemoDatabase, but it does not work with our company database.

This also leads to Marketing Automation problem, they cannot load contacts from the group, then "pause" the campaign with the error "Group is null". This doesn't even work with our ACT V21, too.


It seems like the API can't pull the contact from our database due to format or something.


I have called ACT! and they said our database may be corrupted, so we need to contact the 3rd party database repair service. Unfortunately, we do not have the budget for that repair. 


We tried every option in ACTDIAG but no luck.


I would like to ask if anyone has encountered this similar issue before and point us to some directions? Thank you and we really appreciate that.



New Member
Posts: 6
Country: USA

Re: ACT v22.1 Address book is blank

I am having a similar issue. Installed Act v23 on server - no previous Act installation.

Went all out and created a copy of our main db, moved it to the new server, opened it in v23, shared it.

Set up email prefs on server. Everything worked really well. Email attached very quickly.


On my desktop, removed Act 21. Installed v23. Connected to converted db. Set up Outlook prefs. Could see attachments from server trial.

Created new email. Got pop-up to confirm db connection for Outlook. Never accepted. Always got the "oops" message.


Read your post. Didn't think it was a corrupted db. So, I created a brand new empty db on server. Did the above, email attachment worked. Shared db and opened it on desktop, same issues. 


Reread your post about it working on the demo but I was sure you were testing on the server and, of course, the demo would work - you're on the same machine. Everything works well if you the db is on the same machine. So, I decided to share the demo after setting up outlook prefs.


Opened demo on desktop, set Outlook prefs and surprise, surprise, surprise! When I created an email, the connection popup accepted the OK and a history item was created just fine in the demo from the desktop app! So, I don't think your database is corrupt. It appears that the demo has something set in it that we, the users, are not aware of. 


Next, I am going to make a copy of the Demo and see if that one works as well.


I have a ticket submitted hoping that I will get a fast response since all our remote workers are coming next week and I would like to get this new api connection working. It appears to be a much better solution.


John Wollman 

New Member
Posts: 6
Country: USA

Re: ACT v22.1 Address book is blank

Well, I'm not sure what happened over the weekend but when I opened the full copy of the db on my desktop and sent an email after updating the outlook prefs, Outlook did not ask for a password for the db. I sent a couple of test messages and they both attached immediately.

I was hoping to have some more troubleshooting data to help narrow the problem down. However, this is a much better outcome!

Again Act v23.3.