Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT is ignoring anything I tell it :-)

New Member
Posts: 17
Country: Canada

ACT is ignoring anything I tell it :-)

This is a little difficult to describe.

A large Act Database had to be moved from one server to another because the original server was being decommissioned.  The original database used an old version of ACT, had not been maintained, it had many duplicate records that the users wanted to retain.  The database was exported, a new database was defined on the new server (the users wanted a couple of additional User fields).  The data was imported into the new database.  No problems.  However, the new database was created on the server’s local drive, which was very small.  It should have gone on the corporate storage used by the server (we weren’t aware it existed).  The server admin. people insisted it be moved there and they undertook to move it.  We would have preferred to back it up and restore it in the new location but.... nerds know best. 

What follows is a list of problems that occurred and big question mark;

  1. The transfer seemed to go OK, the record count was right (125,008 records) and the content was checked.
  2. ACT had reverted to its default layout.  Going to Previous Layout didn’t work, there was only one layout.
  3. The staff needed to continue working, which they could not do with the default layout, so we had the database restored from the server backup.  For some reason the incremental backups had not worked so we were left with a backup copy one week old.  About 250 transactions had been lost.
  4. The strategy became one of going to the moved copy, export the lost records and import them into the recovered base.
  5. After the recovery I could not connect to the moved copy .  It’s there, I can see it.  It is larger than the restored copy, but no matter what I’ve tried, ACT goes back to the restored copy.
  6. Here is what I’ve tried so far:
    1. On opening the database, I point act to the pad file of the moved database.  That pad file points to the proper ADF (the right path).  ACT opens the restored database.
    2. I’ve double clicked on the right pad file. ACT opens the restored database.
    3. I’ve double clicked on the right ADF file. ACT opens the restored database.
    4. I went to Preference \ Startup \Startup Databases and changed it from Last opened to Named database giving it the proper path. ACT opens the restored database.
    5. In Preferences \ General I changed Personal Files Location to the proper path for the moved database for Location of File type Databases.  ACT opens the restored database.
    6. The location of the database (path) was verified using Help \ About Act \ Database User Information.  This shows the proper path for the pad file (which points to the moved DB) but shows the path to the restored DB under Database File Location.

This is all that I have found that I can tweak.  I’m beginning to think that down deep in ACT’s dungeon ACT is dredging up that old path and using it no matter what I tell it to do.

Any ideas?

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: ACT is ignoring anything I tell it :-)

If you haven't updated the restored database very much and would rather use the moved copy (125,000 records), the customized layout should be be in the original copy of the Layouts folder - you can copy it to the new moved copy of the database.  It would be under the 'databasename-database files/layouts' folder.

 

To ensure there is no confusion due to the names of the databases, here is an option:

- stop the SQL Server (ACT7) service

- copy (not move or cut) the ADF and ALF files, and the 'database files' folder of the restored database and paste them into a new folder (can be sub-folder of original)

- start the SQL Server (ACT7) service

- rename the file names (ex: add 'New' to the beginning) - ensure that the file names are identical (do not change the extensions)

- open this new copy of the database using the ADF

 

Microsoft SQL has a lock on the database files, that is most likely what causes your incremental backups to fail.  It is best to use the ACT! Scheduler to create backups of the database (*.zip) and then have the backup files included in your backup program.

 

Greg Martin
Sage
New Member
Posts: 17
Country: Canada

Re: ACT is ignoring anything I tell it :-)

Thanks. This would solve the problem I had originally with the copied base. However, my immediate problem is that I can no longer access that copied base. ACT goes to the recovered base no matter how I've tried to get it to go to the copied base.
New Member
Posts: 17
Country: Canada

Re: ACT is ignoring anything I tell it :-)

Thanks.  Please refer to the list of what I've attemped.  Is there a way to force ACT to go to the database I told it to go to or as a minimum to tell me why it did not go there?

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: ACT is ignoring anything I tell it :-)

I was recommending the copy of the database files and renaming them in case your existing copies of the database had the same file names; that could have been causing the confusion opening the database.  You can reset your ACT! preferences to make it 'forget' which database was last used - this may resolve the issue, here is an article with instructions: KB Article 14770

 

I recommend using the section titled: "Alternate Method: Manually Rebuilding Preferences".

Greg Martin
Sage