Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT for Web IIS error

Copper Contributor
Posts: 6
Country: USA

ACT for Web IIS error

Not sure where things are going wrong, but I keep getting the error message that there is a duplicate web.config when I look at the setting for the Web ACT!. The install for ACT goes without any errors and I use the typical install. When I test the Web Server in the Web Site Admin tool I receive an error message - Sage ACT! was unable to connect to the server. Please verify the IIS 6.0 compatability is enabled. I walked throught the steps to verify the application pool is set to 32 bit, but still get the error.

 

I've attached an image - see below. I removed any web sites that I had and reinstalled ACT! for web several time and I still get this. Any help would be great. Thanks.

 

 

 

 

 Web Config error message

Nickel Super Contributor
Posts: 352
Country: Canada

Re: ACT for Web IIS error

The image didn't show up for me but any chance this is on a Windows 7 machine?  Windows 7 has IIS 7.5 and seems to default to running applications with .NET Framework v4.0 instead of v2.x that ACT! needs.  If you don't have any other web apps running, you could try changing the default app pool to use .NET v2 instead.

 

I still had a secondary issue that required support to tweak the config file but the duplicate error you mention went away after changing the target framework.

 

Cheers,

Len

Len Kamerman
ACT! Certified Consultant

Act E-mail Marketing Trainining Course:

http://actsoftware.training
Copper Contributor
Posts: 6
Country: USA

Re: ACT for Web IIS error

Len - I changed the Application pool from DefaultAppPool which was running version 4.0 to Classic .NET AppPool V2. and the error message is gone. When I test the the web server from the Web Site Admin tool I still get the error - Unable to connect - Please verify that IIS 6.0 compatability is enabled. I've gone into the advance settings of the AppPool and verified that the "Enable 32 bit applications" is set to True. That should correct the 32/64 bit issue. Is there another place to update this?

 

I am running Windows 2008 Server R2.

Nickel Super Contributor
Posts: 352
Country: Canada

Re: ACT for Web IIS error

Jim,

 

Make sure that IIS 6.0 compatibility is enabled.

 

I can't recall myself where to do that but this appears to be it, from a quick Google'ing:

 

  • Click Start, click All Programs, click Administrative Tools, and then click Server Manager.
  • Right-click Roles, and then click Add Roles.
  • Click Next to get to the Server Role Screen.
  • Click Next.
  • Click Next to get to the Roles Services for the Application Server.
  • Select the checkbox next to Web Server (IIS) Support. When the Add Roles Wizard box comes up, click Add Required Role Services, and then click Next.
  • Click Next to get to the Web Server Role Services, keep the existing checkboxes that are marked and mark the checkbox next to IIS 6 Management Compatibility, and then click Next.
  • Click Next, and then click Next.
  • Click Install
  •  

    If that doesn't do it, I'd suggest you get with support (Sage offers free "getting started" support for 30 days from purchase for technical/install issues) or pull in a local ACC (a good technical one)

    Len Kamerman
    ACT! Certified Consultant

    Act E-mail Marketing Trainining Course:

    http://actsoftware.training
    New Member
    Posts: 7
    Country: USA

    Re: ACT for Web IIS error

    Any fix for this?  I contacted support and they told me to hold down the CTRL key to add in a database to the web, and it worked, but I would like to get rid of the error when I click test!

    New Member
    Posts: 7
    Country: USA

    Re: ACT for Web IIS error

    Found the solution to mine here:  http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2013...

     

    Seems I had two ports set which was causing it to error.  Removed the extra port and now it works.!

    Platinum Super Contributor
    Posts: 5,275
    Country: USA

    Re: ACT for Web IIS error

    Glad to see you were able to resolve the issue.  And Thank You for posting the resolution!

     

    Greg Martin
    Sage