Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT database sharing disables itself

Copper Contributor
Posts: 18
Country: New_Zealand

ACT database sharing disables itself

Sage ACT! Premium 2011 Version 13.1.111.0, Hotfix 1

Windows 7 (64b)

Shared database

 

We are sharing a database across 3 PCs in a peer to peer network.

All of a sudden about 6 months ago the database sharing would disable itself . I have to go to the PC where it is stored, log on as administrator and re tick the box.

 

Anyone got any ideas why this is happening and how to fix?

CheersJohn

Copper Elite Contributor
Posts: 257
Country: Australia

Re: ACT database sharing disables itself

Hi John

 

There can be a few reasons for this to happen. Most likely it would be related to an antivirus/firewall issue. Either a new antivirus program installed recently, or possibly an auto update.

Please refer to this knowledge base article ID 24235 for some possilble solutions.

 

Hope this helps.

Cherie Buttsworth
ACT! Certified Consultant
Simply PC
cherie@simplypc.com.au
Copper Contributor
Posts: 18
Country: New_Zealand

Re: ACT database sharing disables itself

Problem is that it is random. Stays ticked for a while then disables. Act.exe is listed as "allowed" on firewall.

Copper Elite Contributor
Posts: 257
Country: Australia

Re: ACT database sharing disables itself

You also need to have SQLSEVR.EXE added.  There's actually quite a list of processes and ports and need to be allowed sometimes for ACT to run smoothly.  Please also ensure that the UAC is disabled.

Cherie Buttsworth
ACT! Certified Consultant
Simply PC
cherie@simplypc.com.au
Copper Contributor
Posts: 18
Country: New_Zealand

Re: ACT database sharing disables itself

Yep SQL.SEVR.EXE was added. Would be nice to know what processes and ports need attention. Do you have a list I can check off?

Cheers

John

Nickel Super Contributor
Posts: 397
Country: USA

Re: ACT database sharing disables itself

[ Edited ]

CLICK ...   Using your Anti-Virus/Firewall Software with Sage ACT!   (Basic Anti-virus Configuration too)

 

CLICK...  How to Disable User Account Control (UAC) in Windows® 7 & Windows Server® 2008

Never Notify level - and restart the computer

 

I suggest  share the database on your server from the folder   C:\Users\Public\Documents\ACT\ACT data\Databases  (Naturally you must distribute a new PAD file - )

 

.PAD file is direct access to the database from Users workstation  - do not need a shared network drive or folder  -  do not need map a drive letter to the network - Check that the database is shared on the ACT! server (Tools - Database Maintenance - Share Database)

 

Best Regards,

Copper Elite Contributor
Posts: 257
Country: Australia

Re: ACT database sharing disables itself

Hi John

 

The original KB article I posted contained the link to how to use your AV/firewall with ACT.  It takes you to the same KB that Juan has provided.

 

Cherie Buttsworth
ACT! Certified Consultant
Simply PC
cherie@simplypc.com.au