Community
Showing results for 
Search instead for 
Do you mean 
Reply

[ACT! by Sage Premium 2009 (11.0)] Problem with silent installation

New Member
Posts: 1
Country: Germany

[ACT! by Sage Premium 2009 (11.0)] Problem with silent installation

[ Edited ]

Hello everybody,

 

I'm trying to get a silent installation of ACT! Premium 2009 (11.0) running on a Win7 (x86) VirtualMachine as described in the knowledgebase-guide over here.

 

Recording the silent installation (also with a proper Win7 (x86) VM) went fine so far: with the standard installation procedure ACT! is installed correctly and the setup also creates the desired "issconfig.iss" file. But when I reset the VM (using a snapshot right before the ACT-installation) and try to install ACT! by using the silent method, the setup shows up in the taskbar for less then a minute and then simply disappears. There is no ACT! being installed and the created "installation_output.log" says "ResultCode=-3".

For this error the troubleshooting-paragraph says "Required data not found in the Setup.iss file - Please make sure you have recorded the .iss file correctly. This can also be caused by incorrect formatting of the command line". I checked the .iss file and the formatting of the command line but i can't see any failure(s).

 

Curious test-chronicle: With the first silent installation I recorded (also on the proper Win7 (x86) VM) I was able to do a silent installation. Only thing I didn't want it to do is to start ACT! after installation automatically. So I tried to customize an entry in the "issconfig.iss". After that I tried another silent installation on the resetted VM. At this point the silent installation initiated and didn't install anything for the first time. "ResultCode=0" meaning "Success" obviously was not true. So I resetted everything again: the one modified entry in "issconfig.iss" and the VM, too. But now - with having everything the way it was when the silent installation of ACT! truly succeeded - the installation didn't work out, too (same behaviour and same logfile output "ResultCode=0". Then I tried to record new silent installations in various ways (changing paths and ways of initiating the setup) all with the same result.


Finally I tried to record an installation without the .ini [EDIT: the exact name is SilentInst.ini] file (inside the SI directory) that predefines some options for the setup. This caused the behaviour and "ResultCode=-3" I mentioned first.

 

 

At this point I don't know what else to do/try - I'm stuck.

Has anybody an idea what else I can do?