Showing results for 
Search instead for 
Do you mean 

ACT V21 Premium download error RESOLVED

Silver Super Contributor
Posts: 2,206
Country: United_Kingdom

ACT V21 Premium download error RESOLVED

[ Edited ]

Just did another and working as expected again so just 2 machines had this problem over the weekend. Looks like they have corrected the issue.


Also got this from Daniel from Tech Support so thought I would share it here.


I have seen this before. Generally what causes this is an incomplete installation. I would recommend that disabling any anti-virus during the install.  



Just started to see a major error in downloaded ACT Premium V21 Software installations.


Correct Premium software downloaded but when installed showing as Pro in top left-hand corner. Help confirming it is Premium. Open Premium database in Trial mode.


Then does not recognise Premium licence Key.


Think it maybe slipstreaming wrong patch as part of installation. Started happening Friday.


Was on installations upgrade from V16 Premium





New Member
Posts: 1
Country: USA

Re: ACT V21 Premium download error RESOLVED

[ Edited ]

Very similar problem with v21 Premium installation.


I only had one computer and server to install. I started with the server install but something had gone wrong as it was taking 3-1/2 minutes to load the database. Installed the computer and same result, 3-1/2 minutes to load the database. So, I figured I would reinstall the server (upgrade from 2012 Pro version on both).


I performed an uninstall on the server, renamed the Act! folders, renamed the Act! keys in the registry, and reinstalled. I opened it up and the 30-day trial had ended and it was now Act! Pro and not the Premium version I had installed. Repeated the process and same result, Pro instead of Premium and not on the 30-day trial (it was day 4 in the 30-day trial). Repeated the process but also removed all references to the programs GUID in the registry and also renamed the old license folders as well, Protexis folders in the x86 directory and Protexis folder in the programdata which holds two hidden/system files and deleted references to Protexis in the registry (the folder would be in the %AppData%\Protexis folder if installed only for the current user instead of all users). That finally installed the correct Premium version but was not in 30-day trial mode, neither Act! tech support or sales had any resolution for us to "try" the software before purchasing and was forced to buy the software if we wanted to try it out. After getting my registration code I registered the server without any issue, and the 3-1/2 minutes to load the database was now less than 10-seconds.


Now onto the computer since the only thing to do there was to license it but when I opened Act! Premium on the computer it was now Premium Plus, and the simple uninstall, rename the folders and registry keys, and after reinstallation, it still opened Premium Plus. I found the uninstall tool on Act!'s website and tried that after another uninstall, even though it only says it was only good up to v18. The uninstall tool cleaned up the registry completely of references to Act! and the Protexis keys and data, and only left behind a few files in the two Act! folders on the hard drive. Renamed the leftover folders and reinstalled and was finally running Act! Premium. After the first reinstall, our 30-day trial was over (after 5-days), and after the 2nd reinstall after using the uninstall tool the 30-day trial was still over, so it did not correct that issue. But all I needed to do was register since I had a license code now, but now the option to pick "Country" was not available. The only was to pick the country as to use the arrow keys in the number pad after turning off Num Lock, which I found that fix here in the Act community site.


After all of this, v21 looks nice so far. The installation process is very buggy though.


Computer - Windows 7 64-bit

Server - Windows Server 2016