Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT V18 Group Reports

Accepted Solution Solved
Bronze Elite Contributor
Posts: 1,410
Country: United_Kingdom
Accepted Solution

ACT V18 Group Reports

Client upgraded from ACT 2012 to V18.1

 

Group reports now only reporting on about half of the total reports in database even when filters all set correctly. Has anyone else seen this?


Accepted Solutions
Solution
Accepted by topic author ch1p
‎06-02-2016 03:14 AM
Bronze Elite Contributor
Posts: 1,410
Country: United_Kingdom

Re: ACT V18 Group Reports

Hi

 

I did build a new Group List report on the server and had the same issue.

 

No groups were private or limited access.

 

Did some more digging and it was ignoring one of the Group record managers even though ALL was selected. Again running the report missed this manager on desktop version but included him or WEB version of same report (Sale settings on both report runs.). The record manager of the Group was not important for the client so changed to one that ACT would report on. Will take a copy of their database and run more tests on my demo machine when I have more time to see if I can find why this 

View solution in original post


All Replies
Bronze Elite Contributor
Posts: 1,410
Country: United_Kingdom

Re: ACT V18 Group Reports

Thiss just got more odd. Using the desktop version results as above on server and remotes. Using the server via ACT for WEB and the group reports run as expected from the same database.

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: ACT V18 Group Reports

Do you mean that not all the reports show? Or that they only report on half the records?
Bronze Elite Contributor
Posts: 1,410
Country: United_Kingdom

Re: ACT V18 Group Reports

Hi Mike

 

All the group reports I tried only showed around half the groups. No logic in it that I could see as some main groups and some Sub groups. Run the same report with correct filters for all groups in the ACT for WEB connection on the same server and database and it shows all groups !!!!

Platinum Elite Contributor
Posts: 6,653
Country: USA

Re: ACT V18 Group Reports

Any chance that it involves dynamic membership?

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Bronze Elite Contributor
Posts: 1,410
Country: United_Kingdom

Re: ACT V18 Group Reports

Thanks Roy

 

Worth a look but don't think so.

 

Will let you know.

 

Moderator
Posts: 131
Country: United_Kingdom

Re: ACT V18 Group Reports

Hi there, do any of the groups have any access restrictions on them at all? Are they set to private or limited access?

 

Have you tried creating a new Group report? I'd be interested to see if you had the same problems with a new one too.

Platinum Elite Contributor
Posts: 6,653
Country: USA

Re: ACT V18 Group Reports

I would look to see if the missing contact were always dynamic. It sounds like it's intermittent so I would look for any consistency.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Solution
Accepted by topic author ch1p
‎06-02-2016 03:14 AM
Bronze Elite Contributor
Posts: 1,410
Country: United_Kingdom

Re: ACT V18 Group Reports

Hi

 

I did build a new Group List report on the server and had the same issue.

 

No groups were private or limited access.

 

Did some more digging and it was ignoring one of the Group record managers even though ALL was selected. Again running the report missed this manager on desktop version but included him or WEB version of same report (Sale settings on both report runs.). The record manager of the Group was not important for the client so changed to one that ACT would report on. Will take a copy of their database and run more tests on my demo machine when I have more time to see if I can find why this 

Platinum Elite Contributor
Posts: 6,653
Country: USA

Re: ACT V18 Group Reports

Chip

I recently had a problem with a group report that wouldn't retain the all all user filter preset. I was able to trace the problem to part of a large block of non XML code in the report template that appears to control the report runtime filtering. I could hack the code and get an all users filter setting but it would net stick if I tried to change the user filter preset. I suspect that your problem is related to the problem I experienced. Most of the code for the ACT! reports, both the Component One engine and the editor is over 10 years old and seems to be starting to show it's age. 

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129