Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT Synchronization not updating fields from remote database

New Member
Posts: 4
Country: USA

ACT Synchronization not updating fields from remote database

We just updated to ACT V17.2 (hotfix 2), to be compatible with Windows 10.  We have a server, and 4 remote databases.  When we make a change to fields in a remote database, then synchronize, the field does not change on the server database.  If you click the "history" tab on the server, you can see the field history has updated, but the field didn't update.  See image below as an illustration.  I've tried all 3 "reindexing" options in ACTDIAG, and I've tried to repair the database, and I've tried re-creating one of the remote databases to see if this problem would go away.  This has put a hold on our business and we need help!!  Any suggestions?

 

In this example (below), I wrote "test" in the last results of a contact record, on a remote database.  The field was originally empty. I synchronized, opened the server database, and I can see that "test" was logged in the history, but it's not in the field (see highlighted in red).

 

ACT Sync error.PNG

 

This was the database sync log file from that session:

 

ACT Sync Log.JPG

New Member
Posts: 4
Country: USA

Re: ACT Synchronization not updating fields from remote database

I should add: this happens to many fields I've tested: in the contract records, and in opportunity records. The server does not acknowledge the field change ,and in the other remote databases (once they're sync'd) I cannot see them there either. I should also mention - the server machine is stil running windows 8.1 and the remote databases are Windows 8.1, and Windows 10.
Bronze Super Contributor
Posts: 1,564
Country: United_Kingdom

Re: ACT Synchronization not updating fields from remote database

Have you refreshed the view after the sync?

David Shaw
Act! Certified Consultant since 2001
Office:    +44 (0)1483 714507
Mobile: +44 (0)7977 567 318
E-Mail:    dshaw@act4u.org 
Administrator
Posts: 4,024
Country: United_Kingdom

Re: ACT Synchronization not updating fields from remote database

Hi Jace,

This is indeed quite strange. Could you test by creating a brand new database, and a remote, and then make a few changes and checking if they sync correctly?
New Member
Posts: 3
Country: USA

Re: ACT Synchronization not updating fields from remote database

We are having the same issue with version 16.3 Hot fix 1.  Did you find an answer to your problem?

Administrator
Posts: 4,024
Country: United_Kingdom

Re: ACT Synchronization not updating fields from remote database

Hi urgemedia,

Have you tested using my suggestion above? This would help us troubleshoot the issue with a bit more insight, although this might be outside the scope of what I can help you with on the Community. It might require a phonecall to support.
New Member
Posts: 3
Country: USA

Re: ACT Synchronization not updating fields from remote database

I have not done that yet

New Member
Posts: 4
Country: USA

Re: ACT Synchronization not updating fields from remote database

I did get it fixed: I had to zip up my database and send it to ACT support. They fixed it almost immediately and it's been working for a few months now without a problem. I asked them if it was something I could have done myself, and they said no - so I'm not sure what was wrong but I'm glad it is working.
New Member
Posts: 3
Country: USA

Re: ACT Synchronization not updating fields from remote database

Thanks!  We may do the same then