Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT! Scheduler UI prompts UAC warning with ACT! 2013 SP (15.1)

Platinum Elite Contributor
Posts: 14,384
Country: Australia

ACT! Scheduler UI prompts UAC warning with ACT! 2013 SP (15.1)

[ Edited ]

Greig, here's another for you to test ... I've replicated this on Win7 and Win8.

If you have UAC turned on, SchedulerUI will cause it to pop-up when you login to Windows or if you start it from ACT!

 

[Edit: Subject edited to match topic]

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT! Scheduler UI prompts UAC warning with ACT! 2013 SP (15.1)

I have reproduced this issue and will report it to our development team for investigation. Thank you for bringing this to our attention.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: ACT! Scheduler UI prompts UAC warning with ACT! 2013 SP (15.1)

Still an issue with Act! v16
And, for some reason worse ... the backups it creates can't be opened (or backed up) till they get security manually changed
Copper Contributor
Posts: 83
Country: Australia

Re: ACT! Scheduler UI prompts UAC warning with ACT! 2013 SP (15.1)

Hi,

 

Is there plans to fix this issue?  Turning off UAC is not really the best solution and the run as admin did not seem to work.  http://kb.swiftpage.com/app/answers/detail/a_id/36600/kw/

 

Anyone have a work around that does not involve turning off UAC?

 

Thnaks

Damon

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: ACT! Scheduler UI prompts UAC warning with ACT! 2013 SP (15.1)

Copper Contributor
Posts: 83
Country: Australia

Re: ACT! Scheduler UI prompts UAC warning with ACT! 2013 SP (15.1)

Hi,

 

Here is a link that explains how to make UAC exceptions for applications.

 

http://social.technet.microsoft.com/wiki/contents/articles/19900.how-to-make-uac-exception-for-appli...

 

I have tested this on my workstation which has the UAC nag when opening the Act! Scheduler ,  Windows 7 Pro (32bit).  I have also tested on a Windows 8.1 (64bit) Laptop.  Act V16 on both machines.

 

In both cases I can now open the Act! scheduler with no UAC nag message.

 

Thanks

Damon

 

Copper Contributor
Posts: 23
Country: United States

Re: ACT! Scheduler UI prompts UAC warning with ACT! 2013 SP (15.1)

I tried Damon's solution for a Windows 10 PC and it works there as well. Interestingly, after this change the Act Scheduler UI can success start and stop the scheduler service but it cannot make any modifications to the tasks.

 

In the end, I didn't end up keeping this solution. With Windows 10, I can finally disable the Act Scheduler UI as a startup item and it stays disabled. I have tried this many times before on Windows 7 unsuccessfully. Even if I ran msconfig and unchecked it as a startup item, it still seemed to start up every time. However, with Windows 10 it stays disabled. The UI (and therefore the UAC prompt) doesn't happen at login and the tasks still run. If I need to make changes, I can manually run the UI and do so.

 

I may still use Damon's solution on a few Windows 7 PCs.