Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT Premium for Web v9 on SBS2008

Accepted Solution Solved
New Member
Posts: 6
Country: Australia
Accepted Solution

ACT Premium for Web v9 on SBS2008

I currently have it installed on SBS2003.

 

I am going to move it to SBS2008 premium. I went to install it this morning and it told me it was going to convert my 64 bit Web and ASP to 32 bit, which freaked me out and I cancelled the install.

 

Has anyone got good advice on this process, The migration has been fraught and I would like to keep the companyweb and outlook owa as is working thanks.

 

I could install it on the Server 2008 I get with the premium if that is the better way to go. Your thoughts would be appreciated


Accepted Solutions
Solution
Accepted by topic author asc0tta
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT Premium for Web v9 on SBS2008

APFW 2009 does require that IIS be configured for 32-bit mode, per KB Article 22988. This would only be an issue if your other web apps require IIS in 64-bit mode. And yes, you should be able to install SQL (Standard or Express) and APFW on another SBS 2008 server, as long as IIS is configured to 32-bit mode.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

View solution in original post


All Replies
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT Premium for Web v9 on SBS2008

Hello,

I would not recommend trying to installing ACT! for Web 2007 (9.x) on a Server 2008 system, as that version is not supported on that OS, especially if the OS is 64-bit. You would need to upgrade to ACT! for Web 2009 (11.x) for Server 2008 and 64-bit compatibility.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 6
Country: Australia

Re: ACT Premium for Web v9 on SBS2008

My misakte, we have v11 for Web.

 

Here is the scenario.

 

Currently running on SBS2003 Server. Migrating to SBS2008.

 

We are running and use companyweb and OWA and they are up and running on new server.

 

I think I am right in that ACT cannot run in 64-bit mode. Therefore I cannot install on the SBS2008 server.

 

Because I bought SBS2008 premium, I can run it on the 2008 Standard with the SQL version that came with it ?

 

 

Solution
Accepted by topic author asc0tta
‎09-25-2015 03:20 AM
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT Premium for Web v9 on SBS2008

APFW 2009 does require that IIS be configured for 32-bit mode, per KB Article 22988. This would only be an issue if your other web apps require IIS in 64-bit mode. And yes, you should be able to install SQL (Standard or Express) and APFW on another SBS 2008 server, as long as IIS is configured to 32-bit mode.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Bronze Elite Contributor
Posts: 2,548
Country: New_Zealand

Re: ACT Premium for Web v9 on SBS2008

Grieg,

Being MS Small Business Server 2008 and hence a domain controller, it seems from others comments in newsgroups that this may not be supported.

Can you check? 

Graeme Leo
Xact Software - consultants and developers
Follow us on Twitter and check out our Blog


New Member
Posts: 6
Country: Australia

Re: ACT Premium for Web v9 on SBS2008

I can confirm that ACT install OK onthe 2008 standard server with SQL 2005 installed. No surprise there. That is the way I decided to go.

 

I now only have ASP and other permissions issues to sort. The desktop clients all work, and the database restore worked fine too.

 

Thanks for your help people.

Bronze Elite Contributor
Posts: 2,548
Country: New_Zealand

Re: ACT Premium for Web v9 on SBS2008

Is it ACT! Premium for Web 2009 ( ACT! 11.0) or ACT! Premium 2009 and is it on Small Business Server 2008?

Graeme Leo
Xact Software - consultants and developers
Follow us on Twitter and check out our Blog


New Member
Posts: 6
Country: Australia

Re: ACT Premium for Web v9 on SBS2008

Hi it is ACT! by Sage Premium 2009 (11.0) Version 11.0.1.500 it is running on Windows Server 2008 std.

 

I cant get past the test in Web Site administration yet. Its complaining about DevExpress.Data stuff.

 

 

I cant find ANY of the registry entries expected for ASPNET_REGSET.

 

The Client on the servre works fine so its obviously ASP.NET.     My web.config "appears" to be wanting to write stuff to HKLM, but that key doesnt exist so I would expect failures.

 

I am banging my head now and frustration usually brings contempt.

Bronze Elite Contributor
Posts: 2,548
Country: New_Zealand

Re: ACT Premium for Web v9 on SBS2008

Sage Premium 2009 (11.0) Version 11.0.1.500 ? Are you sure it isn't ACT! Premium for Web 2009 on the server. It is only the ACT! Premium for Web product that has a Web Administration tool.

Graeme Leo
Xact Software - consultants and developers
Follow us on Twitter and check out our Blog


New Member
Posts: 6
Country: Australia

Re: ACT Premium for Web v9 on SBS2008

That was cut and paste from Help and About, rather than me trying to figure out revs etc. I thought that may make it easier.

 

It has the Web Administration tool in the desktop GUI.

 

When I run the test it fills the screen with html. Unfortunately I cannot read it all as it goes below the Windows bar. I have run the Basic stuff from IIS and it connects fine using the APFW user I have set up, but apart from permissions on the web site this user is not as far as I am aware registered with ASP.NET.

 

As I said the IIS6 Compatability is installed on the server.