Community
Showing results for 
Search instead for 
Do you mean 
Reply

[ACT Premium V16!] Strange Word Interop problem

Copper Contributor
Posts: 150
Country: Belgium

[ACT Premium V16!] Strange Word Interop problem

[ Edited ]

 

We're encountering a very strange problem again.

 

We have some in-house developped software that uses Word Interop to generate a few documents.

We recently got a new laptop, Windows 8.1 x64 Dutch, Office 2013 Home & Business (Click To Run) 32Bit.

 

After installing Act V16 our own software crashes on generating documents using Word Interop. Uninstalling Act fixes it, reinstalling brings it back. Tried uninstalling Act and office and reinstalling them but the same problem reappears after installing Act. (We installed Office first, Interop worked, then installed Act, interop stopped working.)

 

If we run our application as administrator it works though. The error we're seeing is a "System.Runtime.InteropServices.ComException" at "System.Runtime.RemotingServices.AllocateUninitializedObject(System.RuntimeType)"

 

We tried disabling the Act Add-ins in word, but even though they show as inactive add-ins, the Act menu is still there and all Act add-in functionality in Word is still working, so no success on that end.

 

Anyone have any idea as to what we can try to get this working?

 

- Edit

 

We have  a few more PC's running Office 2013 Home & Business on Windows 7 X64 and those don't seem to be having the problem. It only seems to appear in combination with Windows 8.