Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT! Premium 2012 creates wrong iis7 virtual directory for ActInternetSync - SEE FIX BELOW

New Member
Posts: 8
Country: United_Kingdom

ACT! Premium 2012 creates wrong iis7 virtual directory for ActInternetSync - SEE FIX BELOW

[ Edited ]

On Windows Server 2008, using ACT Premium 2012 - 14.0.572.0, it appears installing ACT! Internet Sync creates the wrong virtual directory name.

 

It creates "Act Internet Sync" and not ActInternetSync.

 

Please advise on recreating the correctly named virtual directory and associated permissions.

Kind Regards

Paul Holoway

 

New Member
Posts: 8
Country: United_Kingdom

Re: ACT! Premium 2012 creates wrong iis7 virtual directory for ActInternetSync

The details are stored in %windir%\System32\inetsrv\config\applicationHost.config

 

Open Notepad and press CTRL-F  and search for ACT Internet Sync

 

<application path="/ACT Internet Sync">
         <virtualDirectory path="/" physicalPath="C:\Program Files\ACT\ACT for Windows\ACT Internet Sync\" />
         <virtualDirectory path="/ActInternetSync" physicalPath="C:\Program Files\ACT\ACT for Windows\ACT Internet Sync\" />
</application>

 

and further down the page

  <location path="Default Web Site/ACT Internet Sync">

 

These are the incorrect details - please advise what the correct settings in this file should be.

 

Kind Regards

Paul Holoway

Platinum Super Contributor
Posts: 5,275
Country: USA

Re: ACT! Premium 2012 creates wrong iis7 virtual directory for ActInternetSync

Hello Paul,

Welcome to the Sage ACT! Online Community!

 

Try updating the 'Manage Connection Information' option within the remote database, to do this:

- in remote database > go to Tools > Synchronization Panel

- select 'Manage Connection Information'

- for Connection Type > update the URL to include '%20' in each of the spaces.  (ex: act%20Internet%20sync)

- click Finish to save the change and test the sync

 

Another option would be to try renaming the virtual directory to remove the spaces.  I haven't tested if this is possible on Server 2008.

Greg Martin
Sage
New Member
Posts: 8
Country: United_Kingdom

Re: ACT! Premium 2012 creates wrong iis7 virtual directory for ActInternetSync

[ Edited ]

There are three parts to getting this to work:

 

In C:\Windows\System32\inetsrv\config\applicationHost.config file

under site name="Default Web Site"  

RENAME <application path="/ACT Internet Sync"  TO <application path="/ACTInternetSync" 

 

Near the bottom of the page

RENAME <location path="Default Web Site/ACT Internet Sync"> TO <location path="Default Web Site/ACTInternetSync">

 

In C:\Program Files\ACT\ACT for Windows\ACT Internet Sync\web.config

ADD the following lines

<system.web>

   <httpRuntime   executionTimeout="300" />

</system.web>

 

There is a section called system.web but is not in use, so I created the section below.

It fixes the issue of HttpException Request Timed Out ASP.NET work error:

 

Event code: 3001
Event message: The request has been aborted.

 
Application information:
    Application domain: /LM/W3SVC/2/ROOT/ACTInternetSync-1-129639344479687500
    Trust level: Full
    Application Virtual Path: /ACTInternetSync
    Application Path: C:\Program Files\ACT\ACT for Windows\ACT Internet Sync\
    Machine name: SERVER
 
Process information:
    Process ID: 4036
    Process name: w3wp.exe
    Account name: NT AUTHORITY\NETWORK SERVICE
 
Exception information:
    Exception type: HttpException
    Exception message: Request timed out.
 
Request information:
    Request URL: http://domain.com/ActInternetSync/SyncRemoteFactory.soap
    Request path: /ActInternetSync/SyncRemoteFactory.soap
    User host address:
    User: 
    Is authenticated: False
    Authentication Type: 
    Thread account name: NT AUTHORITY\NETWORK SERVICE
 
Thread information:
    Thread ID: 8
    Thread account name: NT AUTHORITY\NETWORK SERVICE
    Is impersonating: False
    Stack trace:

 

 

In the event viewer, error 10016 is shown.

 

I got round this by Start - Run and type: dcomcnfg

Open Component Services

Expand Computers --> My Computer --> DCOM config

Right Click on IIS WAMREG admin service and select properties

Select Security tab

Press Launch and Activation Permissions Edit button

Add NETWORK SERVICE

Tick Local Launch and Local Activation

Press Ok twice

Close Component Services

 

Restart IIS or the server

 

I have also been able to add a custom port number for the sync by creating a new Website in IIS and assigning a different port number and moved the contents of <application path="/ACTInternetSync" ....      </application> from Default Web Site into the newly created website in C:\Windows\System32\inetsrv\config\applicationHost.config file

 

Hope this help with some of your internet sync issues.

Kind Regards

Paul Holoway