Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT Prem 16 Missing fields

Copper Contributor
Posts: 77
Country: USA

ACT Prem 16 Missing fields

I just upgraded from ACT Premium 2011 to ACT ver 16 Premium.   I had added many new fields over the years to the database, but on upgrading to ACT ver 16,  I noticed that several of the fields are missing on the "Contact Info" tab.  They show up in the "Define field" list.    But as I want to place them in gthe Design Layout, these fields are simply not there.   Where the heck did they go?   Jim 

Copper Elite Contributor
Posts: 232
Country: Germany

Re: ACT Prem 16 Missing fields

Hi Jim,

 

if they are "missing" then they are probably in a different tab, as the layout is not showing fields that are placed somewhere.

 

you may want to consider to build a new layout (maybe a copy from the Standard Layout)

 

regards

 

Ingo Lange

www.crmaddon.oom

ACC since 1995
Developer of Addons for ACT

CrmAddon Factory
+1 203 541 0040
Copper Contributor
Posts: 77
Country: USA

Re: ACT Prem 16 Missing fields

Ingo:    The fields are there somewhere, because when I try to add a field with the same name, the system says that field already exists.   Also when I go to "Design Layout" and use my cursor to select that area (even though that area is blank) , the field outlines do show up.  Something funny doing on with this, but I am not a techy to know how to fix this.     Jim

Platinum Elite Contributor
Posts: 6,668
Country: USA

Re: ACT Prem 16 Missing fields

I'm going to start off by making a guess that the missing field labels do show on the layout but the fields don't. If so this doesn't sound good. What appears to have happened is that when the database schema was updated from ACT! 2011 to ACT! 16 that somehow the contact table spillover tables were given a different ID so that the contact layout can't locate the fields in the spillover table. I don't know if there is an easy fix. First I would test by adding the missing fields as columns to the contact list view and see if they show up and if the data is present. If so, one fix would be to relink the missing fields to the layout in the contact layout designer. Another thing to try if you have a backup of the ACT! 2011 database to do a restore as of the backup and let it be updated again and see if that fixes the problem.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Copper Contributor
Posts: 77
Country: USA

Re: ACT Prem 16 Missing fields

Roy:   Just sent this to a techy, so I might be repeating myself, sorry.

 

I just upgraded from ACT Premium 2011 to ACT ver 16 Premium.   I had added many new fields over the years to the database, but on upgrading to ACT ver 16,  I noticed that several of the fields are missing on the "Contact Info" tab.  They show up in the "Define field" list, but as I want to place them in the Design Layout, these fields are simply not there.   Where the heck did they go?  

 

Well now I found them they are still there, but just not showing up,   this appears to be a technical issue and I don’t believe something I have done.      One photo attached shows that these fields are gone, the next photo shows that if I go to Design Layout and highlight that area it shows the fields are still there.    

 

Roy, the labels AND the fields are still there.  It is curious, if I go into the Design Layout and click on View Properties,  the size of the Contact Tab area is 65,535 x 65,535.    My old 2011 Prem computer is up and running and it shows these Contact TaB fields area to be about 1634 x 1120 pixels.    Something is really wrong here.     And I think somehow that large area is covering up adn interferring with those missing fields.   It is strange I can not decrease that area to say 1920x 1120.  I change the size fields and they just revert back to 65,535 x 65.535.     This is interferring somehow, but I am not techy enough to figure this out.  Not even sure I have explained this well enough for someone to even understand this. 

 

I cant restore as I am too far into this now, and my previous data base would be missing a couple weeks of data.   

Platinum Elite Contributor
Posts: 6,668
Country: USA

Re: ACT Prem 16 Missing fields

Go to the layout designer for that layout and the fields should show but they won't have any name in the field. click on the field and open the properties panel (press F4 to open) and then look for Filed Data and you can assign the correct database field to the field in the layout. You'll need to do that for each missing field. Save the layout changes and you should be back in business.

Roy Laudenslager
ACT! Certified Consultant
ACT! Report Expert
Durkin Impact Report Designer
www.techbenders.com
royel@techbenders.com
541-343-8129
Copper Contributor
Posts: 77
Country: USA

Re: ACT Prem 16 Missing fields

Roy:   I appreciate your calling me on Thursday afternoon to give me a few minutes of your time to resolve this issue.  I am a bit frustrated that ACT only has the 30 day support period and my support period expired just a few days ago.  The problem that I had was too technical for me to solve on my own and therefore difficult to explain in words.  Yet you talked me thru and resolved the issue in a few minutes.   It was a complete surprise that you called and very generous to give me a few minutes of your time.   I am now back on track and I appreciate very much your solving this issue for me.  

 

All:   It turns out that there was a corruption issue and an Access screen of some sort was shielding my view of all the "Contact Tab" fields (while in the Design Layout view).  Once Roy discovered this he had me simply deleted that Access screen and all was fixed. Problem solved.   Thanks again.

 

Jim N