Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT! Object Reference Error When Printing

Accepted Solution Solved
tgp
Copper Contributor
Posts: 30
Country: United States
Accepted Solution

ACT! Object Reference Error When Printing

ACT Premium 2009 V11.1

When printing reports all users on the network get an "Object reference not set to an instance of an object" error and are unable to print.  This is true for print previews, going directly to print, etc.  Trying to generate a PDF will just take forever and not actually generate anything.  This seems to be happening with all reports/templates.  Here is how we are printing: Go To File>Print>Printout type: Reports>select the report and click print.>Select current company>Click OK and you will receive the error.

So far I have tried: 
Database check and repair.
restarting ACT
Copying over existing report with the report from a laptop with a remote database and working report print.

No luck.  Any ideas?  Thank you


Accepted Solutions
Solution
Accepted by topic author tgp
‎09-25-2015 03:20 AM
tgp
Copper Contributor
Posts: 30
Country: United States

Re: ACT! Object Reference Error When Printing- Solved!

[ Edited ]

Solved:

 

Greig- Thank you for your help.  I have resolved the issue.  I noticed some companies in ACT did not have all the required fields filled out i.e. their phone number which may have been part of the issue. 

 

The key issue though is that the Record Manager needs to be updated if it is currently set to someone who is no longer with the company i.e. their account is set to inactive.  Once those issues were fixed I could print the report. Smiley Happy

 

Thanks Again!

View solution in original post


All Replies
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT! Object Reference Error When Printing

Hello tgp,
From the information you provided, is it only the network users that receiving the error? The remote database users are not? If this is case, can you try having a network user open a local database on their machine, like the demo (ACT11Demo) and see if the issue occurs?

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

tgp
Copper Contributor
Posts: 30
Country: United States

Re: ACT! Object Reference Error When Printing

Greig,

 

Thank you.  I added the report/form to the reports folder for the Act11demo database on a network machine.  It works fine.  I have followed the information here http://kb.sagesoftwareonline.com/app/answers/detail/a_id/24350#s14 regarding to opening a print preview without luck.  I do have a number of duplicate contacts but I have tried printing from multiple companies with the same result.  Any ideas?

 

Thank You

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT! Object Reference Error When Printing

So the users are able to run the reports locally, but not through the network? If this is the case, you may want to look at the permissions to the database files folder (i.e., [database name]-database files) for the database on the server. Make sure "Full Control" is granted to "Everyone".

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

tgp
Copper Contributor
Posts: 30
Country: United States

Re: ACT! Object Reference Error When Printing

Greig,

 

Thank you for the advice.  Yes it works locally with the demo database but not the network.  I checked and the permissions were already set to full control.  I also reset them to full control with the same results.

 

I just discovered something interesting.  The issue seems to be specific to printing/previewing the report for the Current Company.  If I select All Companies, the print and preview works but of course creates a ton of reports. Any ideas?

 

Thank You

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT! Object Reference Error When Printing

[ Edited ]

This is not a reported issue in ACT! 2009 (or any subsequent versions) for what you are describing. I was not able to reproduce it in the latest version (2012). It seems to be either a database or network specific issue. Any way you can make a backup of the database on the server, restore it locally on a client machine (using the Restore As option), then test with that local copy? This will help narrow the possible cause.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Solution
Accepted by topic author tgp
‎09-25-2015 03:20 AM
tgp
Copper Contributor
Posts: 30
Country: United States

Re: ACT! Object Reference Error When Printing- Solved!

[ Edited ]

Solved:

 

Greig- Thank you for your help.  I have resolved the issue.  I noticed some companies in ACT did not have all the required fields filled out i.e. their phone number which may have been part of the issue. 

 

The key issue though is that the Record Manager needs to be updated if it is currently set to someone who is no longer with the company i.e. their account is set to inactive.  Once those issues were fixed I could print the report. Smiley Happy

 

Thanks Again!

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT! Object Reference Error When Printing- Solved!

I like your solution and will test it for inclusion in our Knowledgebase. Thanks for posting this!

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 1
Country: USA

Re: ACT! Object Reference Error When viewing emails

Re: ACT! Object Reference Error When viewing emails.

 

I have this problem with the newest version 2013 and it is not resolved. I am so tired of problems with ACT.  I have used this for 20 years and they can never get it right. It should be a simple product to use, but it is not. Can you assit me Greg?