Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT! 2013 Premium Synchronization Problem

Copper Contributor
Posts: 26
Country: Switzerland

ACT! 2013 Premium Synchronization Problem

On a new client/server installation with ACT! 2013 Premium, German Edition, I have installed Internet Synchronization with one Remote Database.

 

All steps in the synhronization on the client are successfully finished, but in the last step (error checking) the following error occurs:

 

"Synchronzation failed. Server Error Description: Unable to purge users. Exception has been thrown by the target of an invocation."

 

I have absolutely no idea how to solve this. All instructions are gratefully accepted.IMG_20130416_125441.gif

Stefan Koehli
ACT! Cerified Consultant
KÖHLI INFORMATIK AG
Bronze Elite Contributor
Posts: 2,117
Country: United_Kingdom

Re: ACT! 2013 Premium Synchronization Problem

Hi Stefan,

Have you done a Scan and Repair on the Master and the remote dBs?

Vivek Gargav
Caldere Associates Ltd.
www.caldere.com
vgargav@caldere.com
My Blog
Copper Contributor
Posts: 26
Country: Switzerland

Re: ACT! 2013 Premium Synchronization Problem

Hi Vivek,

Yes, I did on both sides.

Stefan Koehli
ACT! Cerified Consultant
KÖHLI INFORMATIK AG
Bronze Elite Contributor
Posts: 2,117
Country: United_Kingdom

Re: ACT! 2013 Premium Synchronization Problem

If you set the error logging to verbose (level 4) in the Actsage.exe.config file on both sides, and then try again so as to generate the error could you post up screen grabs of the logs here so we can have a look through them?

 

If you are not sure how to do this, here is the KB:

http://kb.sagesoftwareonline.com/app/answers/detail/a_id/14398/kw/actsage.exe.config

Vivek Gargav
Caldere Associates Ltd.
www.caldere.com
vgargav@caldere.com
My Blog
Copper Contributor
Posts: 26
Country: Switzerland

Re: ACT! 2013 Premium Synchronization Problem

I have set to loglevel 4.

I have attached the newest ACTLOG.XML from the client, when sync was running, hope this is what you mean

 

Here ist he errormessage from the SYNCLOG.XML on the server:

 

    <SyncMessage Timestamp="04/19/2013 09:49:23" Type="Message" Category="Sync" Severity="Error">
      <Message>Failed to purge users on the server. Unable to purge users. Exception has been thrown by the target of an invocation.
   at Act.Shared.Licensing.LicenseManager..ctor()
   at Act.Framework.Synchronization.Utils.SyncEntity.GetPurgeUsers(CommandLoader cmdL, LicenseManager licenseManager)</Message>
    </SyncMessage>

 

Stefan Koehli
ACT! Cerified Consultant
KÖHLI INFORMATIK AG
Bronze Elite Contributor
Posts: 2,117
Country: United_Kingdom

Re: ACT! 2013 Premium Synchronization Problem

Ok thanks for that.

 

The application log looks ok, only comlaining about Outlook sync which is normal if it hasn't been enabled.

 

Have you worked through the following KB article:

http://kb.sagesoftwareonline.com/app/answers/detail/a_id/14516/kw/sync%20troubleshooting

Vivek Gargav
Caldere Associates Ltd.
www.caldere.com
vgargav@caldere.com
My Blog
New Member
Posts: 3
Country: USA

Re: ACT! 2013 Premium Synchronization Problem

Hi,

 

Sorry to revive an old thread, but I can find no other mention of this error anywhere. I have about 5 remote database users who all started experiencing this at the same time. Scan/repair is no help.

 

The syncs show as completing successfully on the master db host... and my users say that everything appears normal aside from this error message at the very end of their sync.

 

Did you ever discover the cause/solution?

New Member
Posts: 2
Country: Germany

Re: ACT! 2013 Premium Synchronization Problem

We do have the same problem.

 

I have 4 remote users.

We were working with Windows 7, Office 10 and Act 13 before.

Everything was working smoothly. and remote sync was working perfectly as expected.

 

Then we had to upgrade/replace machines for various reasons.

We bought ACT V17 and started updating the Server (Windows Server 2012 R2).

After that we updated the Version on the machines. 1 Laptop which had a remote database was working still fine and that's the machine which was using the remote database daily. The laptop broke short after that and i had to replace it.

In the meantime. All other remote machines that we had do have the issue mentioned above and shown in the Screenshot.

Now i do not have a single machine working with a remote database. I have also tried re-creating all remote database without success. Installing everything from scratch with disabled uac etc, even turning UAC off in registry and have a totally unsecure pc with full admin rights didn't changed  anything. the problem persists.

 

Furthermore, when a user forgets to sync or is on holiday or this machine is used very rare and the sync question comes up ("You haven't synced for (xxx) days, would you like....?")

This message comes now up every time even so we synced (which of course failed at the end.

 

If anybody has a solution for that, please let me know!

Machines are now running Windows 7/8 and Windows 10, Office is 2010/2013

 

 

<Message>

<![CDATA[Die_x0020_Synchronisierung_x0020_ist_x0020_fehlgeschlagen._x0020_Server_x0020_Error_x0020_Description_x003A__x0020_

Unable_x0020_to_x0020_purge_x0020_users._x0020_Exception_x0020_has_x0020_been_x0020_thrown_x0020_by_x0020_the_x0020_

target_x0020_of_x0020_an_x0020_invocation._x000D__x000A__x0020__x0020__x0020_at_x0020_Act.Shared.Licensing.LicenseManager..ctor

_x0028__x0029__x000D__x000A__x0020__x0020__x0020_at_x0020_Act.Framework.Synchronization.Utils.SyncEntity.GetPurgeUsers_x0028_

CommandLoader_x0020_cmdL_x002C__x0020_LicenseManager_x0020_licenseManager_x0029_bei_x0020_

Act.Framework.Synchronization.Remoting.SyncRemoteClient.LogSyncResult_x0028__x0029__x0020_in_x0020__x003A__

x0020_Zeile_x0020_0]]></Message>

Administrator
Posts: 4,024
Country: United_Kingdom

Re: ACT! 2013 Premium Synchronization Problem

Hi mw_act,

Thanks for letting us know all the troubleshooting steps you have already taken with this issue.
In this case, due to the complexity of the issue, I would suggest giving our support team a call and working with them on more in-depth troubleshooting.
New Member
Posts: 2
Country: Germany

Re: ACT! 2013 Premium Synchronization Problem

Good morning Gary,

 

that's what i did first, but unfortunately i do not have a support plan.

However, if i buy a software that claims to run under the given os/office combinations, it should be able to solve anyway, regardless of support plan or not. Can i sign one? Yes i could, but i have only the issue since i updated to the machines to w 7/8/10 in combination with Act 17. When i had W7 and Act premium 2013 installed, that worked out well with all machines and i thought, may somebody here had the same problem and found a solution. Below is the answer from the support team.

 

 

Thank you for your Email to Act! Technical Support. As you do not currently have a support contract in place with Swiftpage, the only support we can provide via telephone/Email is with registration queries. You can access our Knowledgebase and Community Forum where Information from our team of product experts and powerful Act! Users can help you discover the answers to questions you have about your Act! Product?