Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT! 2012 SP1 HF2 fails on PremWeb

Platinum Elite Contributor
Posts: 14,384
Country: Australia

ACT! 2012 SP1 HF2 fails on PremWeb

Applied fin on all workstations, but on the server (running Premium Web, I get:

 

---------------------------
ACT!
---------------------------
Hotfix failed to apply.
---------------------------
OK   
---------------------------

 



The hotfix.log is as follows

This is the ACT! HotFix.

Applied 1/03/2012 10:50:31 PM

Minimum ACT! Version for this HotFix: 14.1.108.0
Version of this HotFix: 14.1.108.2
Products this HotFix is compatible with: ACT14PremiumACT14StandardACT14PremiumWeb
ACT! version is: 14.1.108.0
Network Sync version is: 14.1.108.0
ACT! product is act14premiumweb
ACT! locale is AU
Copied C:\Program Files\ACT\Act for Web\Act.Hotfix.dll
Copied C:\Program Files\ACT\Act for Web\Act.Framework.dll
Copied C:\Program Files\ACT\Act for Web\Act.UI.TabPage.dll
Copied C:\Program Files\ACT\Act for Web\APFW\bin\Act.Web.dll
Act.Framework.dll failed to copy for internet sync.
The process cannot access the file 'Act.Framework.dll' because it is being used by another process.
Clearing assembly lists
Added Act.Framework.dll to deleteAssemblyList
Added Act.Framework.dll to installAssemblyList
Added Act.UI.TabPage.dll to deleteAssemblyList
Added Act.UI.TabPage.dll to installAssemblyList
unGACed Act.Framework.dll
unGACed Act.UI.TabPage.dll
GACed Act.Framework.dll
GACed Act.UI.TabPage.dll
Regasm'd Act.UI.InternetExplorer.Plugins.AttachFile.dll
bFailed True

HotFix completed
*********************

 

Note: stopping the sync service and exiting the sync service app didn't change the result

Tuned Listener
Posts: 9
Country: United States

Re: ACT! 2012 SP1 HF2 fails on PremWeb

I ran into this same issue setting up our new training lab.  The hotfix installed just fine on all of the workstations, though, failed on the instructor machine, which was running the Network Sync Service (and these were brand new machines, all identical Win 7 Pro, AMD 64 bit).  Checking the hotfix.log showed the same error you were getting.

 

I rebooted into Safe Mode and ran the hotfix and still received the same error.

 

Booting back into standard Windows and then uninstalling the Network Sync Service allowed the hotfix to install without issue (didn't even have to reboot).  Post hofix install, I simply reinstalled the Network Sync Service.

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: ACT! 2012 SP1 HF2 fails on PremWeb

Hotfix 2 was recalled anyway ... and they haven't re-released it.

It appears that Sage just don't do QA testing before releasing patches of hotfixes any more.