Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT 2012 PREM w/Hamachi...NEED HELP!

New Member
Posts: 7
Country: United States

ACT 2012 PREM w/Hamachi...NEED HELP!

I am new to this comunity, as I have not run into many problems with ACT in the past!  I am a long time ACT user and have recently moved up to the ACT 2012 Premium version for our company.  I am having several problems with the sync of the remote database to the main database.  In the past it has always been fairly straight forward.  I am using Hamachi and this seems to work great!  I have ACT installed on my desktop in the office and i am currently a "remote user".  I cannot seem to sync, I have read what I think, are all the articles on "how to create....." and i think I have done them all step by step.  What I am unclear(or simply frustrated) with at this point....not sure if I have it all set up correct?  I am simply using the application sync through the hamach VPN.  I have told the remote database where to look as directed.  I am still getting the error "ACT is unable to connect to the sync server". Check to be sure "accept incoming syncs" is enabled in the main database and that the Network Sync service is running.  Also be sure you are connected to your network."  With message, now I think I should be using the sync service. Can some one help eliminate some frustrations???  Thanks for all and any help provided!!!!

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT 2012 PREM w/Hamachi...NEED HELP!

[ Edited ]

Hello SaraH,
Welcome back to the Sage ACT! Community. If using the Network Sync Service, you will need to uncheck "Accept Incoming Syncs" on the host machine - this setting is only needed if using the built-in ACT! application sync service. Make sure the Network Sync Service is running on the host machine and that your remote machines can access the sync port being used (65100 by default) via Hamachi. Also, check this Knowledgebase article to ensure you have properly setup ACT! with Hamachi:
http://kb.Sagesoftwareonline.com/cgi-bin/Sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2333...

If you have, then the issue is most likely with your Hamachi connection, so you may need to contact them for assistance.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 7
Country: United States

Re: ACT 2012 PREM w/Hamachi...NEED HELP!

Just to be clear, in this scinerio I do need to be running the network sync service?  I guess this is a place to start?  If so, then i need to run the network sync service only on the host machine or host machine AND remote machines?

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT 2012 PREM w/Hamachi...NEED HELP!

The network sync service need only be installed and running on the host machine.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 7
Country: United States

Re: ACT 2012 PREM w/Hamachi...NEED HELP!

Ok, I am really unsure at this point....Question, do I need the application sync as well as the network sync service?  One or the other?

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT 2012 PREM w/Hamachi...NEED HELP!

[ Edited ]

No, you only need to have one. Application sync is the built-in sync service generally used with ACT! Pro versions. The Premium versions include Network sync which runs as a separate service, allowing users to sync without having to have ACT! open on the server. Checking the "Accept incoming syncs" turns on application sync, which you do not want if you are also running network sync. Sync services only have to run on the machine hosting the main database - they should not be installed and running on the remote machines.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 7
Country: United States

Re: ACT 2012 PREM w/Hamachi...NEED HELP!

Ok, so i am good on that front. I only have Network Sync service running. Unchecked the "accept incoming sync's". All of this is on the host computer! now I get the error about the port? So I changed the port for the network sync service to 65000. Is there a specific number this needs to be changed to work? I also changed the port on the remote database. Any other suggestions??
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT 2012 PREM w/Hamachi...NEED HELP!

What is the error message and when does it occur? Also, what version of Windows is your host machine running?

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

New Member
Posts: 7
Country: United States

Re: ACT 2012 PREM w/Hamachi...NEED HELP!

The error message is as follows " could not start sync server. Act has encountered an error, please check that the sync server port is able to listen for incoming syncs". This happens when I start the network sync server. The host machine has Win XP professional on it.
Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT 2012 PREM w/Hamachi...NEED HELP!

Ok. Try changing the port on the server to 65100 or 65101. You will also have to make the change in the "Manage Connection Information" in the Synchronization Panel for the remotes, after you get a port to work on the server.

Also, refer to this Knowledgebase article to add exceptions to the Windows firewall (if running) for ACT!, SQL Server, and the sync port:
http://kb.Sagesoftwareonline.com/cgi-bin/Sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=1942...

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.